Installing Lazarus/de

From Free Pascal wiki
Jump to: navigation, search

Deutsch (de) | English (en) | Español (es) | Suomi (fi) | Français (fr) | Magyar (hu) | 日本語 (ja) | 한국어 (ko) | Nederlands (nl) | Português (pt) | Slovenčina (sk) | Tiếng Việt (vn) | ‪中文(中国大陆)‬ (zh_CN)

Contents

Überblick

Für Menschen, die einfach Lazarus installieren wollen und es für die Programmierung nutzen möchten, ist die einfachste Methode ein neues, einigermaßen stabiles Release (wie ein Linux ".rpm" Package, einen Windows ".exe" Installer oder ein Mac OS X ".dmg" Package) herunter zu laden und zu installieren. Sie können die Abschnitte über Linux oder Windows mit dem Titel "fpc binaries" oder die ersten Absätze in dem Abschnitt über die Installation von Lazarus unter Linux oder Windows lesen. Die meisten der restlichen Informationen können sicher ignoriert werden.

Für jene, die sich an der Entwicklung des Compilers oder der IDE beteiligen wollen, oder für jene, die die allerneuesten Werkzeuge haben wollen, ist eine Installation aus den Quelldateien notwendig, und der Großteil dieser Informationen ist relevant.

Lazarus bietet zwei Hauptteile:

  • LCL - die Lazarus Component Library
  • IDE - das RAD Werkzeug

Diese wiederum sind abhängig von

  • FPC - dem FreePascal Compiler
  • FCL - der FreePascal Component Library, diese enthält die meisten der nicht-graphischen Komponenten von Lazarus

Lazarus - Systemvoraussetzungen

  1. FreePascal Compiler, Packages, und Quellen. (*wichtig*: von der selben Version/Datum)
  2. Ein unterstütztes Widget Toolkit
    Win32
    Das native Win32 API kann benutzt werden, oder das Qt Widgetset
    Linux/xxxBSD
    GTK+ 2.x or Qt : Die meisten Linux Distributionen und *BSDs installieren ohnehin die GTK+ 2.x Bibliotheken. Sie können sie auch finden unter http://www.gtk.org.
    Qt wird auch von allen Distributionen unterstützt (automatisch installiert, wenn Sie KDE vorziehen).
    Mac OS X
    Sie benötigen die Apple Entwickler Tools. Siehe unten unter: Installation unter Mac OS X. Qt kann ebenfalls eingesetzt werden.

Die FAQ - Frequently Asked Questions Datei ist verfügbar unter http://www.lazarus.freepascal.org . Einige der Fragen sind zu finden in der lokalen Datei 'FAQ'.

Das Qt Widgetset wird unter Linux 32/64, Win32/64, Mac OS X, Haiku und embedded linux (qtopia) Plattformen unterstützt.
Mehr über die Installation finden Sie auf http://wiki.lazarus.freepascal.org/index.php/Qt_Interface

Die folgenden Abschnitte beschreiben, wie man FreePascal erhält und wie man Lazarus richtig installiert.

Installation des Free Pascal Compilers

Eine ausführliche Diskussion darüber, wie die Free Pascal Compiler zu installieren und erstellen sind, ist hier verfügbar: http://www.stack.nl/~marcov/buildfaq.pdf - es mag ein bisschen zu detailiert sein für einige Benutzer, aber es ist sehr umfassend.

Lazarus 0.9.30 benötigt FPC (FreePascal) Version 2.4.2 oder höher und die kompilierten FPC Bibliotheken und die FPC Quellen müssen die selbe Version besitzen.


Installation von Free Pascal unter Linux

FPC Binärdateien

Die neueste Version von FreePascal, Version 2.4.2, kann von der FreePascal Webseite (http://www.freepascal.org/download.var, und Auswahl eines Mirror-Servers) bezogen werden, oder von SourceForge (http://sourceforge.net/projects/lazarus).

Im Lazarus Downloadbereich (http://www.lazarus.freepascal.org ) können Sie die RPM oder DEB des Free Pascal Compilers (Compiler / Linux) und seine Packages erhalten. Wenn Sie keine RPM-basierte oder Debian-basierte Distribution haben, können Sie die "tarballs" von http://www.freepascal.org downloaden und installieren. Wenn sie die Binärdateien selbst kompilieren wollen, schauen sie im BSD Abschnitt nach.

Instruktionen:

WARNUNG: wenn Sie nicht die RPMs oder Debian-Packages benutzen (sogar wenn Sie vorhaben 'alien' einzusetzen) ist es am Besten, sich den neuesten, stabilen FPC (derzeit 2.4.2) zu besorgen und Lazarus von den Quelltexten zu installieren.

Starten Sie Linux und loggen Sie sich als root ein.

Laden Sie die neuesten Dateien von Sourceforge herunter. Zum Beispiel:

  • fpc-2.4.2-0.i686.rpm
  • fpc-src-2.4.2-0.i686.rpm
  • lazarus-0.9.30-0.i686.rpm

und installieren Sie diese mit:

  • rpm -Uvh fpc-2.4.2-0.6386.rpm
  • rpm -Uvh fpc-src-2.4.2-0.i686.rpm
  • rpm -Uvh lazarus-0.9.30-0.i686.rpm

Debian-Nutzer müssen zurückgreifen entweder auf 'alien' (Warnung, es wird keine fpc.cfg erzeugt) oder auf die Installation mittels 'tarball'.

FPC Quellen

Seit dem Release von Version 2.0 hat FPC zur Verwendung von Subversion (SVN) übergewechselt. Fürs erste gibt es keinen CVS Mirror mehr, daher müssen sie SVN benutzen, um die FPC Quellen zu bekommen.

Herunterladen einen Schnappschusses vom Entwicklungszweig (Version 2.5.1)

Sie können die heutigen Entwicklungsquelltexte (v 2.5.1) herunterladen in Form eines gepackten Snapshots vom SVN Source Repository: Diese Schnappschüsse werden täglich aktualisiert, und spiegeln den Status des Quellrepositorys wider. Sie sind nicht getestet, möglicherweise nicht funktionsfähig und könnten sogar Ihr System zum Absturz bringen. Die Dateien finden Sie auf der Webseite des SVN-Archivs. Das vollständige öffentliche Quelltextarchiv von v2.5.1: http://www.hu.freepascal.org/lazarus/

Verbinden mit dem Source Repository mittels SVN (ersetzt den Abschnitt über CVS)

Als eine Alternative zu den täglichen Zip-Dateien der SVN Quellen, wurde das SVN Repository für jeden zugänglich gemacht, mit Nur-Lese-Zugriff. Das bedeutet, dass Sie den Code direkt abrufen können, und Sie werden wirklich die Last-Minute-Quellen verfügbar haben. Es ist auch eine Methode, die eine geringere Bandbreite erfordert, sobald Sie den ersten Download erledigt haben ("checkout" in der SVN Sprache).

Entwicklungs-Snapshots

Wie macht man das? (Sie müssen natürlich SVN installiert haben. Schauen Sie hier nach für Instruktionen, wie das geht.)

Wechseln Sie (Befehl cd) zum übergeordneten Verzeichnis ihrer Entwicklungsumgebung, z.B.

[]$ cd /home/username/FreePascal

Um das vollständige Quell- Repository abzurufen, alle öffentlich verfügbaren Module, tippen Sie

[]$ svn checkout http://svn.freepascal.org/svn/fpc/trunk fpc

Normalerweise sollten sie diesen Schritt nur einmal ausführen (müssen).

Um die mittels 'checkout' herunter geladenen Quellen zu aktualisieren genügt

[]$svn update fpc


Fixes für 2.4.x

Die Fixes benötigen ein separates Verzeichnis, erstellen Sie ein separates Verzeichnis 'fixes', gehen Sie hinein, und wiederholen Sie das obrige checkout Kommando mit der URL http://svn.freepascal.org/svn/fpc/branches/fixes_2_4:

[]$ cd mysvn/fixes
[]$ svn checkout http://svn.freepascal.org/svn/fpc/branches/fixes_2_4 fpc

und zum Aktualisieren:

[]$ svn update fpc

Die Quellen der Dokumente sind in einem separaten Repository mit Namen fpcdocs. Das Kommando um sie zu erhalten lautet

[]$ svn checkout http://svn.freepascal.org/svn/fpcdocs/trunk fpcdocs

Wenn Sie mehr über Subversion lernen wollen, dann lesen Sie dieses exzellente Subversion Buch, das auch online verfügbar ist in verschiedenen Formaten (kostenlos).

Für die Neugierigen: Sie haben nur Lesezugriff, versuchen Sie nicht, etwas einzustellen :-)

Für mehr Informationen schauen Sie auf der Free Pascal Webseite nach.

Installation von Free Pascal unter Windows

FPC Binärdateien für Windows

Bei weitem der einfachste Weg, eine funktionierende Installation von Free Pascal zu erhalten, ist der Download der aktuellen Windows-Version von Lazarus vom SourceForge Repository [1]. Das Release enthält die aktuellen Versionen des FreePascal Compilers und die FreePascal Bibliotheken ebenso wie die Lazarus IDE.

Wenn Sie von den Quellen installieren wollen, dann lesen Sie weiter!

Sie können die Installations Zip-Datei für FPC 2.4.2 im Free Pascal Downloadbereich http://www.freepascal.org/download.var (dann wählen Sie einen Mirror-Server) erhalten. Installation von den Quellen -- entnehmen Sie dem nächsten Abschnitt, wie man diese erhält -- ist nichts für Anfänger, weil Sie einen funktionierenden Compiler benötigen.

FPC Quellen für Windows

<<<< Sehen Sie den obigen Abschnitt an unter FPC Quellen für Linux, wo die Benutzung von SVN beschrieben ist. >>>>

Der einfachste Weg, um die Free Pascal Quellen zu bekommen, ist via SVN; im nächsten Abschnitt finden Sie mehr darüber. Sie können auch das Package als ganzes herunterladen -- schauen Sie unter http://www.freepascal.org/develop.var nach dem täglichen Snapshot des 2.5.x Versionsbaums.

Windows FPC Quellen via SVN

Sie benötigen einen installierten SVN-Klienten wie TortoiseSVN, um die nachfolgenden Schritte durchführen zu können. Die exakten Befehle variieren zwischen den SVN-Klienten; die nachfolgenden Befehle werden vom Klienten des SVN verwendet, den Sie hier auch herunterladen können.

Erzeugen Sie zuerst ein Verzeichnis für die Quelltexte. Das kann jeder normale Benutzer machen. Erzeugen Sie ein Verzeichnis für FPC (z.B C:\Source), dann geben Sie am Befehlsprompt folgendes ein:

 C:\Source> svn co http://svn.freepascal.org/svn/fpc/trunk fpc

Tipp: Zum Herunterladen/Aktualisieren der letzten Änderungen schreiben Sie einfach:

 C:\> cd Source\FPC
 C:\Source\FPC> svn up

Siehe: http://www.freepascal.org/i386/win32.var. Downloaden Sie FPC als eine große Datei, entpacken Sie diese und starten Sie die install.exe.

Erweitern Sie Ihre PATH Variable um das FPC Verzeichnis:

  • Win98: Bearbeiten Sie 'autoexec.bat' und fügen Sie die Zeile hinzu: PATH=%PATH%;C:\pp\bin\bin\win32
  • WinXP/2000: Computer (Rechtsklick) -> Eigenschaften -> Erweitert -> Umgebungsvariablen -> Systemvariablen -> Edit "PATH", Fügen Sie "C:\pp\bin\bin\win32" dort hinzu.

Dann starten Sie Windows neu.

Nachdem Sie die FPC Binärdateien installiert haben, können Sie die FPC Quellen von Subversion erstellen.

Tipps:

  • Windows (7+) erfordert erweiterte Benutzerrechte für die verwendete Eingabeaufforderung. Im Startmenü rechtsklicken Sie auf "Eingabeaufforderung" und wählen Sie "Als Administrator ausführen".
  • YOUR-PREFIX hängt vollkommen davon ab, wo Sie FPC installiert haben. Zum Zeitpunkt der Erstellung dieses Textes war der Standardort der Binaries auf "C:\FPC", tatsächlich lagen sie aber in "c:\FPC\2.4.2". Unter Linux, waren die 'make install' Skripts so eingerichtet, dass sie einen neuen Unterordner erstellen, falls sich die FPC-Version seit dem letzten Erstellen geändert hat. Die Windows-Skripts machen das nicht. Wenn Sie also den Namen des Unterordners wissen (z.B. 2.5.1 ) können Sie ihn angeben. Weil sich aber die Versionen häufig ändern, wird empfohlen, dass Sie ein einziges PREFIX auswählen und ohne Rücksicht auf die FPC Versionen beibehalten. Ein gutes Prefix ist C:\FPC, aber stellen Sie auch sicher, dass der Ordner C:\FPC\bin\i386-win32\ in Ihrer Pfadvariablen enthalten ist (siehe oben, wie Sie den Pfad einrichten und von der binären Version zur neu kompilierten ändern können).

Anweisungen:

  • Auf der Eingabeaufforderung navigieren Sie zur lokalisierten FPC Quelle. Z.B. geben Sie ein "cd c:\Developer\FPC"
  • Um FPC zu erstellen geben Sie ein "make all"
  • Um einen existierenden FPC zu überschreiben geben Sie ein "make install PREFIX=YOUR-PREFIX"
  • Um die Quellen zu installieren geben Sie ein "make install sourceinstall PREFIX=YOUR-PREFIX"

Kompilieren/Installieren von FPC und Lazarus aus den Quellens von SVN (Win32)

--MD 14:35, 4 October 2010 (CEST)

SCHRITT #1: Erzeugen Sie die Verzeichnisse und besorgen Sie sich die Quellen

Erzeugen Sie folgende Verzeichnisse:

 c:\freepascal\
 c:\freepascal\binutils\
 c:\freepascal\binutils\i386-win32\
 c:\freepascal\fpc\
 c:\freepascal\fpc\2.4.3\
 c:\freepascal\laz\

Sie brauchen einen Kompiler, um einen neuen Kompiler zu erstellen. Besorgen Sie sich ppc386 (den Kompiler) in FTP (unten) und entzippen Sie ihn nach c:\freepascal\binutils\

 ftp://ftp.freepascal.org/pub/fpc/dist/2.4.2/bootstrap/i386-win32-ppc386.zip

Nach der Installation von TortoiseSVN, laden Sie die Quellen von SVN herunter mit einer URL für jedes Verzeichnis, also:

 Dir: c:\freepascal\binutils\i386-win32\
 URL: http://svn.freepascal.org/svn/fpcbuild/branches/fixes_2_4/install/binw32
 Dir: c:\freepascal\fpc\2.4.3
 URL: http://svn.freepascal.org/svn/fpc/branches/fixes_2_4/
 Dir: c:\freepascal\laz
 URL: http://svn.freepascal.org/svn/lazarus/trunk
SCHRITT #2: Erzeugen Sie eine BAT-Datei, um FPC zu kompilieren

Nach allen Downloads, brauchen wir eine Stapeldatei (.BAT), um die Quellen von FPC zu kompilieren. Erzeugen Sie eine neue Datei 'c:\freepascal\makefpc.bat', kopieren und fügen Sie folgendes Skript ein:

 @echo on
 set myversion=2.4.3
 set mypath=c:\freepascal\fpc\%myversion%
 set mybinutils=c:\freepascal\binutils
 set PATH=%mybinutils%\i386-win32;%mypath%\bin\i386-win32;%PATH%
 cd %mypath%
 make distclean
 make all install INSTALL_PREFIX=%mypath% PP=%mybinutils%\ppc386.exe
SCHRITT #3: Erstellen Sie FPC

In einer Eingabeaufforderung (cmd.exe) navigieren Sie zum Verzeichnis c:\freepascal und geben Sie ein: makefpc.bat

SCHRITT #4: Erzeugen Sie die Datei fpc.cfg

Jetzt brauchen wir eine Konfigurationsdatei für FPC. Dies erreichen Sie z.B. mit dem Werkzeug fpcmkcfg im Verzeichnis 'fpc bin'. Schritte:

Wechseln Sie in einer Befehlszeile mit cd in das bin Verzeichnis, z.B. C:\freepascal\fpc\2.4.3\bin\i386-win32.

Geben Sie ein:

 fpcmkcfg -d basepath=C:\freepascal\fpc\2.4.3 -o fpc.cfg
 fpcmkcfg -1 -d basepath=C:\freepascal\fpc\2.4.3 -o fp.cfg


Wenn das bei Ihnen nicht funktioniert, hier ist ein anderer Lösungsweg:

Die nachfolgende Standardtextdatei fpc.cfg zeigt bereits auf die soeben erzeugten Verzeichnisse. Kopieren Sie den folgenden Code in eine neue Datei namens 'fpc.cfg' im Verzeichnis c:\freepascal\fpc\2.4.3\bin\i386-win32

 #
 # Config file generated by fpcmkcfg on 24/12/2010 - 18:17:42
 # Example fpc.cfg for Free Pascal Compiler
 #
 
 # ----------------------
 # Defines (preprocessor)
 # ----------------------
 
 #
 # nested #IFNDEF, #IFDEF, #ENDIF, #ELSE, #DEFINE, #UNDEF are allowed
 #
 # -d is the same as #DEFINE
 # -u is the same as #UNDEF
 #
 
 #
 # Some examples (for switches see below, and the -? helppages)
 #
 # Try compiling with the -dRELEASE or -dDEBUG on the commandline
 #
 
 # For a release compile with optimizes and strip debuginfo
 #IFDEF RELEASE
   -O2
   -Xs
   #WRITE Compiling Release Version
 #ENDIF
 
 # For a debug version compile with debuginfo and all codegeneration checks on
 #IFDEF DEBUG
   -glh
   -Crtoi
   #WRITE Compiling Debug Version
 #ENDIF
 
 # ----------------
 # Parsing switches
 # ----------------
 
 # Pascal language mode
 #      -Mfpc      free pascal dialect (default)
 #      -Mobjfpc   switch some Delphi 2 extensions on
 #      -Mdelphi   tries to be Delphi compatible
 #      -Mtp       tries to be TP/BP 7.0 compatible
 #      -Mgpc      tries to be gpc compatible
 #      -Mmacpas   tries to be compatible to the macintosh pascal dialects
 #
 # Turn on Object Pascal extensions by default
 #-Mobjfpc
 
 # Assembler reader mode
 #      -Rdefault  use default assembler
 #      -Ratt      read AT&T style assembler
 #      -Rintel    read Intel style assembler
 #
 # All assembler blocks are AT&T styled by default
 #-Ratt
 
 # Semantic checking
 #      -S2        same as -Mobjfpc
 #      -Sc        supports operators like C (*=,+=,/= and -=)
 #      -Sa        include assertion code.
 #      -Sd        same as -Mdelphi
 #      -Se<x>     compiler stops after the <x> errors (default is 1)
 #      -Sg        allow LABEL and GOTO
 #      -Sh        Use ansistrings
 #      -Si        support C++ styled INLINE
 #      -SI<x>     set interface style to <x>
 #         -SIcomCOM compatible interface (default)
 #         -SIcorbaCORBA compatible interface
 #      -Sm        support macros like C (global)
 #      -So        same as -Mtp
 #      -Sp        same as -Mgpc
 #      -Ss        constructor name must be init (destructor must be done)
 #
 # Allow goto, inline, C-operators, C-vars
 -Sgic
 
 # ---------------
 # Code generation
 # ---------------
 
 # Uncomment the next line if you always want static/dynamic units by default
 # (can be overruled with -CD, -CS at the commandline)
 #-CS
 #-CD
 
 # Set the default heapsize to 8Mb
 #-Ch8000000
 
 # Set default codegeneration checks (iocheck, overflow, range, stack)
 #-Ci
 #-Co
 #-Cr
 #-Ct
 
 # Optimizer switches for i386 compiler
 # -Os        generate smaller code
 # -O1        level 1 optimizations (quick optimizations)
 # -O2        level 2 optimizations (-O1 + slower optimizations)
 # -O3        level 3 optimizations (same as -O2u)
 # -Oa=N      set alignment to N
 # -OoX       switch on optimalization X. 
 # -OoNOX     switch off optimalization X.
 #               X is one of REGVAR UNCERTAIN STACKFRAME PEEPHOLE ASMCSE LOOPUNROLL
 # -OpCPU     set target processor.
 #             CPU is one of 386, PENTIUM, PENTIUM2, PENTIUM3, PENTIUM4, PENTIUMM 
 
 
 # -----------------------
 # Set Filenames and Paths
 # -----------------------
 
 # Both slashes and backslashes are allowed in paths
 
 # path to the messagefile, not necessary anymore but can be used to override
 # the default language
 #-FrC:\freepascal\fpc\2.4.3/msg/errore.msg
 #-FrC:\freepascal\fpc\2.4.3/msg/errorn.msg
 #-FrC:\freepascal\fpc\2.4.3/msg/errores.msg
 #-FrC:\freepascal\fpc\2.4.3/msg/errord.msg
 #-FrC:\freepascal\fpc\2.4.3/msg/errorr.msg
 
 #IFDEF FPCAPACHE_1_13
 -FuC:\freepascal\fpc\2.4.3/units/$FPCTARGET/httpd13/
 #ELSE
 #IFDEF FPCAPACHE_2_0
 -FuC:\freepascal\fpc\2.4.3/units/$FPCTARGET/httpd20
 #ELSE
 -FuC:\freepascal\fpc\2.4.3/units/$FPCTARGET/httpd22
 #ENDIF
 #ENDIF
 
 # searchpath for units and other system dependent things
 -FuC:\freepascal\fpc\2.4.3/units/$FPCTARGET/
 -FuC:\freepascal\fpc\2.4.3/units/$FPCTARGET/*
 -FuC:\freepascal\fpc\2.4.3/units/$FPCTARGET/rtl
 
 # path to the gcclib
 
 
 # searchpath for libraries
 #-FlC:\freepascal\fpc\2.4.3/lib
 #-Fl/lib;/usr/lib
 
 # searchpath for tools
 -FDC:\freepascal\fpc\2.4.3\bin/$FPCTARGET
 
 #IFNDEF CPUI386
 #IFNDEF CPUAMD64
 #DEFINE NEEDCROSSBINUTILS
 #ENDIF
 #ENDIF
 
 #IFNDEF Win32
 #DEFINE NEEDCROSSBINUTILS
 #ENDIF
 
 # binutils prefix for cross compiling
 #IFDEF FPC_CROSSCOMPILING
 #IFDEF NEEDCROSSBINUTILS
   -XP$FPCTARGET-
 #ENDIF
 #ENDIF
 
 
 # -------------
 # Linking
 # -------------
 
 # generate always debugging information for GDB (slows down the compiling
 # process)
 #      -gc        generate checks for pointers
 #      -gd        use dbx
 #      -gg        use gsym
 #      -gh        use heap trace unit (for memory leak debugging)
 #      -gl        use line info unit to show more info for backtraces
 #      -gv        generates programs tracable with valgrind
 #      -gw        generate dwarf debugging info
 #
 # Enable debuginfo and use the line info unit by default
 #-gl
 
 # always pass an option to the linker
 #-k-s
 
 # Always strip debuginfo from the executable
 -Xs
 
 
 # -------------
 # Miscellaneous
 # -------------
 
 # Write always a nice FPC logo ;)
 -l
 
 # Verbosity
 #      e : Show errors (default)       d : Show debug info
 #      w : Show warnings               u : Show unit info
 #      n : Show notes                  t : Show tried/used files
 #      h : Show hints                  m : Show defined macros
 #      i : Show general info           p : Show compiled procedures
 #      l : Show linenumbers            c : Show conditionals
 #      a : Show everything             0 : Show nothing (except errors)
 #      b : Show all procedure          r : Rhide/GCC compatibility mode
 #          declarations if an error    x : Executable info (Win32 only)
 #          occurs
 #
 # Display Info, Warnings, Notes and Hints
 -viwn
 # If you don't want so much verbosity use
 #-vw
SCHRITT #5: Erzeugen Sie eine BAT-Datei, um Lazarus zu kompilieren

Um Lazarus erstmalig zu kompilieren, erzeugen Sie eine neue Datei 'c:\freepascal\makelaz.bat' und kopieren und fügen Sie folgendes Skript ein:

 @echo on
 set myversion=2.4.3
 set mypath=c:\freepascal\fpc\%myversion%
 set mybinutils=c:\freepascal\binutils
 set PATH=%mybinutils%\i386-win32;%mypath%\bin\i386-win32;%PATH%
 cd c:\freepascal\laz
 make clean all OPT="-glw2"

Tipp: Sie brauchen diese BAT-Datei nur beim ersten Mal. Später könnern Sie Lazarus erstellen über den Menüpunkt 'Werkzeuge > Kompiliere Lazarus'.

SCHRITT #6: Erstellen Sie Lazarus

In einer Eingabeaufforderung navigieren Sie zum Verzeichnis 'c:\freepascal' und geben Sie ein: 'makelaz.bat'


Fertig!

Installation von Free Pascal unter FreeBSD/auto

Die neueste Sammlung von FreeBSD-Ports hat die stabile Version 2.4.4 in 'ports/lang/fpc'. Aber sie ist auf über 94 (!) Packages verteilt und Sie können die Quellen dazu erhalten von '/usr/ports/distfiles/freepascal'.

Führen Sie dies als Benutzer root durch.

[]# cd /usr/ports/lang/fpc && make install && make clean

Eine andere Möglichkeit ist die Verwendung von portinstall.

[]# portinstall fpc

Wenn FPC installiert ist können Sie prüfen, ob es funktioniert, durch ein einfaches Starten von

[]$ fpc

Installation von Free Pascal unter Linux/BSD manuell

Effektiv benötigen Sie

eine Datei mit allen Quellen, oder zwei (FPC und Lazarus)

1. z.B. für FPC ftp://ftp.freepascal.org/fpc/dist/Linux/separate/sources.tar preferably an export (no CVS/ dirs). The above file misses this. 2. eine Schnappschuss der Lazarus-Quellen.

  • irgendeinen funktionierenden Kompiler aus dem 2.4.2 Zweig. Machen Sie eine Überprüfung der Ausgabe von 'ppc386 -i'. Wenn es 2.4.2 bis 2.5.x ist, dan ist es ok.
  • notwendige Packages. (für FreeBSD sind das gtk2, glib2 und GNU make, iconv und gettext)

FPC erstellen:

1. (holen) Sie sich die notwendigen Dateien (FPC Quellen, funktionierender Kompiler) 2. (extrahieren) Sie die tgz-Datein in ein Arbeitsverzeichnis 'work', 3. (erstellen) gehen Sie in work/fpc/ und geben Sie ein

 $MAKE all OPT='-gl'  PP=/path/to/startingcompiler-name-ppc386
(/path/to/ kann weggelassen werden falls sich ppc386 im Pfad befindet)
($MAKE ist 'make' unter Linux und 'gmake' unter BSD)

4. (installieren) ebenfalls in work/fpc geben Sie ein

$MAKE install PP=compiler/ppc386 PREFIX=$THEPREFIX
(THEPREFIX= ist normalerweise /usr/local oder einfach /usr, aber z.B. unter
NetBSD ist es /usr/pkg for ports)
Erzeugen Sie einen Symlink:
  ln -s $THEPREFIX/lib/fpc/2.4.2/ppc386 $THEPREFIX/bin/ppc386
Installieren Sie die Quellen
  $MAKE install sourceinstall PREFIX=$THEPREFIX
Erzeugen Sie einen Symlink zum vorgegebenen Lazarus-Quell-Pfad:
 ln -sf $THEPREFIX/share/src/2.4.2/fpc /usr/share/fpcsrc

5. (konfigurieren) dazu geben Sie ein

 $THEPREFIX/lib/fpc/2.4.2/samplecfg $THEPREFIX/lib/fpc/2.4.2 $ETCDIR

6. (optionaler Test), beobachten Sie, ob 'ppc386 -i' eine Ausgabe liefert, ansonsten erscheint ein Warnhinweis, dass der Benutzer das Verzeichnis $PREFIX/bin zum aktuellen Pfad hinzufügen muss. Kompilieren Sie versuchsweise ein Programm mit -viwn und schauen Sie, ob dabei Fehlermeldungen angezeigt werden. Anmerkungen:

  • Wenn Sie Packagelisten für fpcmake brauchen, müssen Sie sich diese selbst erstellen oder besorgen, (in einem port, oder in einem extra archive) führen Sie eine Dummy-Installation durch nach /tmp/pack und ermitteln Sie die installierten Dateinen mit 'find . >ll'
  • $THEPREFIX und $ETCDIR sollten für den Benutzer konfigurierbar sein. Andernfalls sind lokale Installationen unmöglich.
  • BSDHIER=1 bei allen make-Befehlen erzwingt eine Hierarchie gemäß der BSD-Konventionen.

Installation von Free Pascal unter Mac OS X

Bitte hier weiter lesen (leider nur auf englisch): Installing Lazarus on MacOS X

Installation von Lazarus

Installation von Lazarus unter Linux

Ubuntu 11.04 oder später

Dies ist der einfachste Weg, Lazarus unter Ubuntu zu installieren.

Öffnen Sie ein Terminal und führen Sie folgende Befehle aus:

 wget -c http://silvioprog.com.br/download/install_fpc_lazarus_svn_version.tar.gz
 tar -vzxf install_fpc_lazarus_svn_version.tar.gz
 ./install_fpc_lazarus_svn_version.sh

Sie können Lazarus auch aktualisieren, entfernen oder anpassen mittels der folgenden Skripte:

 http://silvioprog.com.br/download/update_fpc_lazarus_svn_version.tar.gz
 http://silvioprog.com.br/download/remove_fpc_lazarus_svn_version.tar.gz
 http://silvioprog.com.br/download/custom_lazarus_svn_version_800x600.tar.gz
 http://silvioprog.com.br/download/custom_lazarus_svn_version_1024x768.tar.gz

Viel Spass!

P.S.: Es gibt Berichte darüber, dass dieses Skript auch mit Versionen vor Ubuntu-11.04 funtioniert.

Silvio Clecio

Ubuntu / Debian

Der einfachste Weg, sich eine aktuelle, funktionierende Lazarus-Installation zu besorgen, ist der Download der .deb Dateien für FreePascal und Lazarus vom SourceForge-Repository. Hier steht, wie's geht: Getting Lazarus from our Ubuntu repository.

Beachten Sie, dass bei der Installation von den Ubuntu Standardquellen die Free Pascal Quellbibliotheken nicht installiert werden - verwenden Sie die oben beschriebene Methode.

Anmerkung: zumindest unter Linux Ubuntu, ist der Befehl zum Starten von Lazarus von der Konsole startlazarus. Andernfalls, wenn Sie es von einem Debian-Package installiert haben, sollten Sie einen Menüeintrag 'Lazarus' unter Anwendungen/Programmierung haben. (Problem: es gibt eine Überschneidung mit einem Programm, das auch "lazarus" heißt, aus einem "tct" Package unter Ubuntu).


Erstellen von debs auf die einfache Art

Der einfachste Weg - was schon wieder??-, sich eine aktuelle, funktionierende Lazarus-Installation zu besorgen, besteht darin, seine eigenen .deb-Packages zu erstellen mittel folgender Instruktionen:

How to setup a FPC and Lazarus Ubuntu repository

Installation unter Verwendung von rpms

Der zweiteinfachste Weg ist das Herunterladen der RPMs für FreePascal und Lazarus von SourceForge.

Sie müssen die gewählte Version herunterladen von

  • dem Compiler (z.B. fpc-2.4.2-0.i686.rpm)
  • der Pascal Quell Bibliothek (z.B. fpc-src-2.4.2-0.i686.rpm)
  • dem Lazarus Package (z.B. lazarus-0.9.30-0.i686.rpm).

Deinstallieren Sie die alten Packages:

 rpm -ev lazarus
 rpm -ev fpc
 rpm -ev fpc-src

Installieren Sie die neuen Packages:

 rpm -ivh fpc-*
 rpm -ivh lazarus-*

Installation unter Mandriva

Lazarus 0.9.30 unter Mandriva 2010.

Installieren Sie wie weiter unten angegeben, allerdings könnten Sie beim Kompilieren eines Programmes zwei Fehlermeldungen erhalten die besagen, dass Ihnen 'pixbuf 2.0' und 'lgtk-x11-2.0' fehlen. Um dies zu beheben, installieren Sie mit dem Software-Installer 'libdgk_pixbuf2.0_0-devel' und 'libgtk+2.0_0-devel'.

Installation unter Slackware

Installation von Lazarus unter Slackware 13.0

Es gibt keinen wirklichen Unterschied zur Slackware Version 12.2 or 12.0, deshalb sollte das nachfolgend beschriebene Verfahren ebenso gut funktionieren.

Installation von Lazarus 0.9.30, für Benutzer von Slackware 12.0

Folgendes hat unter Slackware-12.0 auf einem Pentium-3 Computer geklappt:

  • Der Free Pascal Compiler (FPC) wird im SUPERUSER Modus installiert.
  • Lazarus wirdn installiert im USER Modus.
  • Der FPC-Compiler wird neu kompiliert.
  • Der Lazarus Integrated Development Environment (IDE) Quellcode wird vom SVN server heruntergeladen.

-- Laden Sie "fpc-2.4.2.i386-linux.tar" in einen Benutzerordner herunter und installieren Sie ihn. Gehen Sie zu diesem Ordner und geben Sie ein:

 bash-3.1$ tar -xvf fpc-2.4.2.i386-linux.tar
 bash-3.1$ su 
 bash-3.1$ password:xxxxxx
 bash-3.1# sh install.sh
 ...
 (nehmen Sie die vorgegebenen Antworten der nächsten 6 Fragen: drücken Sie 6 Mal auf "Eingabe")
 ...
 bash-3.1# exit
 bash-3.2$ fpc
 free pascal compiler version 2.4.2 [] for i386 
 Copyright (c) 2010 ...
 ...
 ...

Sie haben den Compiler installiert. Sie können ihn jetzt neu kompilieren oder nicht, in jedem Fall müssen Sie den Quellcode herunterladen, da er für die Lazarus IDE erforderlich ist.

-- Laden Sie "fpc-2.4.2.source.tar.gz" in ein temporäres Verzeicnis. Falls Sie den Quelltext nicht rekompilieren wollen, dann überspringen Sie einfach diesen Abschnitt. Falls Sie Ihre eigene überstzte Version von FPC ausführen wollen, geben Sie einfach ein:

 bash-3.1$ tar -xvzf fpc-2.4.2.source.tar.gz
 bash-3.1$ cd fpc-2.4.2
 bash-3.1$ make clean all
 bash-3.1$ su
 bash-3.1$ password: xxxxxxxx
 bash-3.1# make install
 bash-3.1# exit
 bash-3.1$ fpc
 free pascal compiler version 2.4.2 [...] for i386 
 Copyright (c) 2010 ...
 ...
 ...

Jetzt haben Sie Ihre selbstkompilierte, funktionierende Version.

-- Der Lazarus-IDE-Editor muss den FPC-Quellcode erreichen. Sogar wenn Sie den FPC nicht neu kompilieren wollen, wird sein Quellcode benötigt. Aber, um etwas Platz zu sparen, ich behalte mir nur eine saubere (unkompilierte) Kopie des Quellcodes. Ich starte wieder mit der Datei "fpc-2.4.2.source.tar.gz" und kopiere sie in den Ordner /usr/local/src/FPC:

 bash-3.1$ su
 bash-3.1$ password: xxxxxxxx
 bash-3.1# cp fpc-2.4.2.source.tar.gz /usr/local/src/
 bash-3.1# cd /usr/local/src/
 bash-3.1# tar -xvzf fpc-2.4.2.source.tar.gz
 bash-3.1# rm fpc-2.4.2.source.tar.gz
 bash-3.1# exit

Die Versionsnummer ist im Ordnernamen "fpc-2.4.2" enthalten. Auf diese Weise kann ich viele Versionen der Compilerquellen behalten und jederzeit zwischen ihnen umschalten.

-- Die Lazarus IDE habe ich in meinem USER "~/lazarus" Ordner und kompiliere ich immer im USER Modus. Üblicherweise lade ich die Datei "lazarus-0.9.30-0.tar.gz" herunter, aber wir können auch die neueste Entwicklerversion vom SVN-Server verwenden:

  bash-3.1$ svn co http://svn.freepascal.org/svn/lazarus/trunk lazarus

Dies ist nur beim ersten Herunterladen nötig. Beim nächsten Mal brauchen Sie nur folgendes eingeben:

  bash-3.1$ svn update

Falls Sie nicht SVN auf Ihrem Computer installiert haben, hier steht, wie Sie es schnell erhalten können:

--Laden Sie die zwei Dateien "subversion-1.4.6.tar.gz" und "subversion-deps-1.4.5.tar.gz" (oder spätere Versionen)herunter. Geben Sie ein:

  bash-3.1$ tar -xvzf subversion-1.4.6.tar.gz
  bash-3.1$ tar -xvzf subversion-deps-1.4.6.tar.gz
  bash-3.1$ cd subversion-1.4.6
  bash-3.1$ ./configure
  bash-3.1$ make
  bash-3.1$ su
  bash-3.1$ password:xxxxxx
  bash-3.1# make install
  bash-3.1$ exit

-- An diesem Punkt haben Sie den Ordner "~/lazarus", der den Quellcode enthält. Sie könne ihn ganz einfach kompilieren:

  bash-3.1$ make clean all

Nach wenigen Minuten stoppt der Compiler:

  ...
  ...
  Linking ../Lazbuild
  987 linescompiled ...
  make [2] leaving ...
  make [1] leaving ...
  bash-3.1$

-- Geben Sie ein:

  bash-3.1$ ./lazarus

WOW! Sie erhalten folgende Nachricht: "Free Pascal sources not found". Folgen Sie den Anweisungen und passen Sie Ihr FPC-Quelltextverzeichnis an im Menü: "Einstellungen -> Umgebung -> Dateien". Wie bereits früher erklärt, zeigt dieses auf meinem Computer auf "/usr/local/src/fpc-2.4.2". Beachten Sie: Falls Sie diesen Ordner ändern, sollen Sie auf "Einstellungen / FPC-Quelltextverzeichnis neu einlesen" klicken.

Voila!

Installation unter OpenSuse

Installation von Lazarus 0.9.30 für OpenSuse 11.1 Benutzer

Der Free Pascal Compiler benötigt:
- Gnu binutils (gnu as, gnu ld, gnu make) These utils can be installed by:

 zypper in -t pattern devel_basis

Lazarus benötigt auch noch diese Komponenten: 1) glib2 devel 2) gtk2 devel

Wichtig: Das Lazarus RPM erfordert die gtk 2 Version, nicht die Version 1.2.

These libraries can be installed by:

 zypper -n install gtk2 glib2

Laden Sie diese binären Dateien (RPM) herunter:

  • fpc-2.4.2-0.i686.rpm (ja, i686 und nicht i386)
  • fpc-src-2.4.2-0.i686.rpm
  • lazarus-0.9.30-0.i686.rpm

und installieren Sie diese. Öffnen Sie dazu eine Terminalsitzung (rechte Maustaste -> Menü: In Terminal öffnen)

 rpm -Uvh fpc-2.4.2-0.i686.rpm
 rpm -Uvh fpc-src-2.4.2-0.i686.rpm
 rpm -Uvh lazarus-0.9.30-0.i686.rpm

Installation aus den Quellen

Wenn Sie die Installation von den Quellen bevorzugen und die Dateien selbst kompilieren, dann folgen Sie diesen Instruktionen. Weil das ganze Lazarus-Zeugs in ein Verzeichnis installiert ist, ist die Deinstallierung sehr einfach und Sie müssen kein root sein, um Lazarus zu installieren. Sie können die tgz Dateien für fpc, fpcsrc und Lazarus vom Download-bereich erhalten oder Sie können sie direkt mittels SVN herunterladen.

Hier ist ein Beispiel für die Installation von 0.9.28 unter Ubuntu 6.06. Wenn Sie Linuxbefehle und bash-Skripte verstehen, wissen Sie, welche Schritte nötig sind. Kopieren Sie einfach das Skript (ändern Sie die Versionsnummer, wenn eine neue Version erschienen ist), fügen es in einen Texteditor ein und speichern es z.B. als "install_lazarus.sh". Geben Sie ihm das Recht zur Ausführung, und starten Sie es in einer Konsole. Beachten Sie: In diesem Beispiel ist FPC installiert im Verzeichnis /opt. Auf die Frage nach dem 'Install prefix' geben Sie also '/opt/fpc' ein.

 #!/bin/sh
 
 #Installieren der benötigten Packages
 sudo apt-get install build-essential
 sudo apt-get install libgtk2.0-dev
 sudo apt-get install libgdk-pixbuf-dev
 
 #Installieren der Free Pascal Quellen
 cd /opt
 sudo wget http://nchc.dl.sourceforge.net/lazarus/fpc-src-2.0.4.source.tgz
 sudo tar -xvf fpc-src-2.0.4.source.tgz
 sudo mv fpc fpcsrc
 
 #Installieren von FreePascal
 sudo mkdir fpc
 cd fpc
 sudo wget http://nchc.dl.sourceforge.net/lazarus/fpc-2.4.2.i686-linux.tar
 sudo tar -xvf fpc-2.4.2.i686-linux.tar
 echo "Enter '/opt/fpc' when prompted 'Install prefix'"
 sudo sh install.sh
 
 #den FPC-Pfad zu PATH hinzufügen
 echo "#FPC PATH" >> ~/.bash_profile
 echo "if [ -d /opt/fpc/bin ] ; then" >> ~/.bash_profile 
 echo PATH=/opt/fpc/bin:"${PATH}" >> ~/.bash_profile
 echo "fi" >> ~/.bash_profile
 
 #Installieren von Lazarus
 cd ../
 sudo wget http://nchc.dl.sourceforge.net/lazarus/lazarus-0.9.30-0.tar.gz
 sudo tar -zxvf lazarus-0.9.30-0.tar.gz
 PATH=/opt/fpc/bin:"${PATH}"
 sudo chmod -R 777 lazarus
 cd lazarus
 make clean all
 ./lazarus

Beachten Sie: Sie müssen den fpc-src Pfad in den Umgebungseinstellungen manuell einrichten.

Download von Lazarus-Quellcode (mittels SVN)

Das Lazarus Repository ist von CVS zu SVN (Subversion) umgezogen. SVN bietet einen einfachen Weg, um Ihre Quellen zu aktualisieren, indem Sie nur die Änderungen downloaden. Dies ist der empfohlene Weg und spart Ihnen eine Menge Zeit. Eine Verbindung ins Internet wird dafür benötigt: Sie müssen aber nicht root sein.

Bitte beachten Sie, dass diese Anweisungen nur für SubVersion gelten, aber es gibt auch ein Git-Mirror-Repository des Free Pascal Compilers und von Lazarus. Siehe Git mirror für Details. Sie können Git auch direkt vom SubVersion-Server benutzen mittels git-svn Links. Siehe Lazarus git-svn für Details.

Lazarus benötigt keine speziellen Rechte, weder während der Installation noch zur Laufzeit.

Mit diesem Umzug haben wir auch die Verzeichnisstruktur der Lazarus-Quellen geändert. Der Hauptunterschied besteht darin, dass alle IDE-Quellen von root in ein separates Unterverzeichnis gewandert sind. Wie Sie sicher verstehen, beinflusst dies die Make-Dateien, die Suchpfade etc. Wir arbeiten an den Reparaturen. Wenn also etwas nicht klappt, lassen Sie es uns bitte wissen.

Jetzt die wichtigste Sache.... Erhalten der Quellen
 []$ svn checkout http://svn.freepascal.org/svn/lazarus/trunk/ lazarus

(oder jedes andere Verzeichnis, wo Sie Ihre Quellen haben wollen)

Bei nachfolgenden Gelegenheiten tippen Sie zum Aktualisieren einfach

 []$ svn update lazarus

Für mehr Informationen über Subversion siehe: http://subversion.tigris.org/

Die SVN Kommandos können üblicherweise abgekürzt werden, z.B. co für checkout und up für update. Wenn Sie auf der Kommandozeile weitere Informationen zu den SVN Befehlen erhalten wollen, tippen Sie einfach: svn help.

Beachten Sie: das CVS ist noch immer erreichbar, aber eingefroren. Dies bedeutet, dass keine neuen Updates mehr eingepflegt werden.

Kompilieren und Starten von Lazarus

Wenn Sie Sich von SVN abgemeldet haben (checkout), ist der nächste Schritt:

Kompilieren von Lazarus
[]$ cd lazarus
[]$ make  (gmake bei BSD)

Wenn FPC korrekt installiert ist, sollte die Kompilierung ohne Probleme arbeiten. Wenn nicht, dann schauen Sie in den FAQ nach.

Starten von Lazarus
[]$ ./lazarus

Die IDE sollte starten. Wenn Sie Lazarus in einem Terminal gestartet haben, können Sie einige Mitteilungen über fehlende Einstellungen sehen. Das ist normal beim ersten Start. Die IDE versucht automatisch herauszufinden, wo der Free Pascal Compiler und seine Quellen installiert sind, indem sie in den gebräuchlichsten Verzeichnissen sucht.

Prüfen Sie die Pfade
Benutzen Sie dazu das IDE Menü:
Einstellungen -> Umgebung -> Dateien

Das 'FPC Quelltextverzeichnis' sollte auf ihr FPC Quelltextverzeichnis zeigen. Dieses Verzeichnis endet normalerweise mit /fpc/ oder /fpcsrc/ (z.B. /usr/src/fpcsrc oder /home/username/freepascal/fpc) und enthält Verzeichnisse wie 'compiler', 'docs', 'fcl', 'rtl' und 'packages'.

Siehe hier für die Dokumentation über diesen Dialog: IDE Optionen.

Hinweis

Um Lazarus zu aktualisieren können Sie folgendes benutzen

[]$ svn update lazarus

dann im Installationsverzeichnis:

[]$ make clean all   (gmake unter BSD)

Dies wird Lazarus neu erstellen und eine IDE ohne Lazarus-Packages erstellen. Um Ihre installierten Packages zu linken, tippen Sie danach:

[]$ ./lazbuild --build-ide=

Gegebenenfalls hängen Sie zusätzliche Optionen an, z.B. wenn Sie ein benutzerdefiniertes Konfigurationsverzeichnis verwenden (d.h. fügen Sie an: --pcp="C:\Documents and Settings\<USER>\Local Settings\Application Data\lazarus-tests"). Siehe lazbuild.

Installation von Lazarus unter Debian GNU/Linux

Debian Packages sind verfügbar bei Sourceforge.

Es sind vorläufige Debian Packages für Lazarus zum Download verfügbar. Lesen sie /usr/share/doc/lazarus/README.Debian sorgfältig bevor sie mit der Benutzung beginnen. Feedback wird benötigt und ist geschätzt. Bitte senden sie ihre Kommentare an Carlos Laviola <claviola@debian.org>.

Installation von Lazarus unter Windows

Die aktuellen Versionen der Windows Lazarus Packages sind sehr einfach zu installieren und sollten ohne Probleme arbeiten.

Es ist sogar möglich, das ganze Lazarus/FPC Package auf einem USB Stick (Kapazität mindestens 256 MB) zu installieren, für die Benutzung in Umgebungen, wo es nicht erlaubt ist, Software auf ihrer Windows Workstation zu installieren oder wo sie keine Administrator Rechte erhalten haben. Sie müssen etwas vorsichtig sein mit der Einstellung der Pfade in den Compiler- und Umgebungseinstellungen und der fpc.cfg Datei. Es mag auch notwendig sein, das Verzeichnis für Testkompilierungen auf ihrem tragbaren Laufwerk zu belassen.

Das Windows Package ist verfügbar von

http://sourceforge.net/project/showfiles.php?group_id=89339

Laden Sie die neueste Version (gegenwärtig lazarus-1.0.10-fpc-2.6.2-win32.exe) herunter und starten sie die Anwendung. Sie werden durch eine typische Windows Installation geführt, in der der FPC Compiler und die Quellen Bibliotheken in der selben Verzeichnisstruktur wie Lazarus installiert werden, und die IDE sollte ohne signifikante Probleme starten und arbeiten, vorausgesetzt sie haben jede frühere Version von Lazarus und/oder FPC deinstalliert (oft zu finden im C:\pp Verzeichnis).

Sie können auch einen Lazarus Schnappschuss verwenden, siehe Lazarus Snapshots Downloads.

Installation von den Quellen

Wenn sie die Installation aus den Quellen bevorzugen, dann folgen sie diesen Instruktionen (Dank an Joe für die anfängliche Schritt-für-Schritt Beschreibung)

Sie müssen die Lazarus Quellen von einem der snapshot Server herunterladen.

Dann entzippen sie diese zum Beispiel nach c:\lazarus . Sie müssen mindestens fpc-2.0.2 installieren, aber ein fpc-2.0.3 oder fpc 2.1.1 Snapshot ist auch möglich. It compiles for me, and lazarus.exe works. Der Pfad zu meinem FPC ist: c:\pp\bin\win32. In diesem Verzeichnis können sie eine Menge exe finden (make, grep, ppc386, und so weiter).

Öfnnen sie eine Kommandozeile. Start -> Ausführen...>cmd oder wählen sie das MS-DOS Icon.

Tippen sie:

cd c:\lazarus
set path=c:\pp\bin\win32;c:\lazarus  //natürlich zuerst an ihre Pfade anpassen
windres -i lazarus.rc -o lazarus.res
make

Wenn sie Glück haben dann können sie: lazarus.exe eintippen. Der Quelltexteditor, Dialoge und der Eigenschafts Editor arbeiten, aber nicht perfekt... Schauen sie und sie werden sehen.

Sie können examples auch so kompilieren:

cd examples
make

Wenn sie Lazarus auf einem anderen Laufwerk extrahiert haben, z.B.: d:\lazarus, kann es passieren, dass sie das gnu Utility für 'make' benötigen. Wenn sie es haben, können sie seinen Pfad nehmen um den path=...;<gmakepath> zu setzen aber es ist einfacher, nicht das Laufwerk d:\ zu wählen.

Das ist alles.

Installation von Lazarus unter FreeBSD

FreeBSD 6+

Die neueste Version von Lazarus im FreeBSD Port Baum ist 0.9.30. We can to install lazarus using FreeBSD ports. (???)

[]# cd /usr/ports/editors/lazarus && make install clean clean-depends

Falls Sie Nachrichten über fehlende Quelltextdateien erhalten, gehen Sie zum [Menü >> Einstellungen >> Umgebungseinstellungen >> Dateien: FPC-Quelltextverzeichnis] und geben Sie das Verzeichnis Ihrer FPC-Quelltextdateien ein. Sie erhalten sie von /usr/ports/distfiles/freepascal

Installation von Lazarus unter PC-BSD 1.0rc1+

You can install Lazarus on PB-BSD by simply downloading the Lazarus PBI from PBI Dir

Note that you must install glib* port from /usr/port/devel/glib* or glib packages by pkg_add -r glib12 glib20. I will fix this in new PBI releases.

[other OpenBSD/NetBSD/DragonFlyBSD goes here]

Installation von Lazarus unter Mac OS X

Die Installation unter Mac OS X ist fast wie unter Linux. Aber sie müssen zuerst die Apple Entwicklerwerkzeuge installieren.

Die aktuelle Version von Lazarus gibt es bei SourceForge: [SourceForge]

Schnappschüsse sind auf den snaphot Servern verfügbar.

Eine ausführlichere Anleitung gibt es, wenn auch nur auf englisch, hier: Installing Lazarus on MacOS X.

Wenn sie alle 3 .dmg Snapshot Dateien installieren, wird dies auch den FPC Compiler und die FPC und Lazarus Quellen installieren. Wenn sie nur Lazarus starten wollen, um ihre eigenen Anwendungen zu entwickeln und kompilieren, brauchen sie die FPC und Lazarus Quellen nicht. Installieren wie oben beschrieben. Wenn sie Lazarus neu übersetzen wollen oder bei seiner Entwicklung helfen wollen, dann sollten sie den Lazarus Quellcode in einem Ordner installieren, bei dem ihre Zugriffsrechte auf Lesen & Schreiben Rechte stehen, wie oben bei Linux beschrieben.

Nach der Installation können sie Lazarus aus dem Ordner /Programme per Doppelklick starten.

Zusätzliche Erfahrungen und Ratschläge über die Installation von FPC und Lazarus

Unter Linux kann es schwierig sein, Lazarus zum laufen zu bringen, wenn sie bereits frühere Versionen von FPC und/oder Lazarus installiert haben. Dann müssen sie sich große Mühe geben, dass die Pfade angepasst werden, so dass nur ihre neuen Versionen aufgerufen werden.

Fallen, die ich herausgefunden habe in verschiedenen Versuchen mit SuSE Linux enthalten:

Die rpm Versionen installieren oftmals FPC in /bin oder /usr/bin, mit den Bibliotheken in /lib oder /usr/lib.

Wenn sie ein make install ausführen bei einer Quellen Version oder ein .tar.gz benutzen, wird der Compiler üblicherweise in /usr/local/bin mit den Bibliotheken in /usr/local/lib installiert.

So if earlier versions have been installed from rpm, make sure all links are changed to reflect the directory structure of your new compiler. The place to make the changes is in /etc/fpc.cfg ; make sure there are no remnant configuration files in your home directory or in your FPC download directory. Typically they are found in ~/.fpc.cfg

Stellen sie sicher, dass die Links in /etc/fpc.cfg auf die korrekten Versionen der Bibliotheken zeigen (particularly if you have older versions still lurking around).

In /usr/local/bin oder /usr/bin gibt es eine Datei namens fpc ; dies ist das executable that is called when you invoke the compiler. One of the first things it does is to open ppc386 in the same directory. This has to be the same version as the fpc file, or can be a link pointing to the true ppc386 in some other directory (such as a library directory, or the fpc directory in your own development space); be sure to update your link if you install a newer version of the compiler.

Try running the compiler from the command line using one of the simple example programs or one which you wrote yourself.

Turning to Lazarus:

Wenn sie einen herunter geladenen Snapshot (.tar.gz) verwenden oder die Quellen von SVN geholt haben, gehen sie in ihr Lazarus Verzeichnis und tippen

make
./lazarus 

und die IDE wird hoffentlich geladen. There may be a message saying it can't find the sources; if so, go to the menu at the top and select Tools -> Options -> Environment and insert the name of the directory where you expect to find your lazarus files (eg ~/FreePascal/lazarus), your compiler (eg /usr/local/bin/ppc386), the FreePascal source directory (eg /usr/local/lib/fpc/$version/fpc or a directory in your own space eg ~/FreePascal/fpc). Then close the dialog and start programming.

You may find further problems when you start programming or compiling; most of these will be related to PATH selection.

Many of the difficulties are dealt with in the Lazarus FAQ, found either on this WiKi site, or a more complete list on the main Lazarus site

http://www.lazarus.freepascal.org/modules.php?op=modload&name=FAQ&file=index

From the top menu select Run -> Compiler Options (or Project -> Compiler Options in more recent releases of Lazarus) and select the Paths tab on the resulting dialog. There are several boxes for entry of paths for Unit files, Include files, Other source files, Libraries etc. For each of these, it is worth pressing the ... (ellipsis) button on the right, and you will be given a blank window for inserting path information, and a lower window giving some suggestions. Select as many as you like (or ALL!) and press the ADD button to transfer the selections to the upper window. When your selection is complete, press OK and move on to the next box. If you know of other paths which need to be followed, press the Browse button associated with each box, and insert the additional paths.

When you think you have got your paths right, try to compile your application. If there are further path-related errors ('can't find unit .......') then go back and check your paths, both in /etc/fpc.cfg and in your Run -> Compiler Options dialog (or Project -> Compiler Options depending on your version).

Once you have got the environment and PATHS correct, it is worth saving the settings to a file, otherwise you will have to go through this process for each new project. In the Run -> Compiler options dialog there is a Load/Save button; select this and then save the setings to the filename of your choice: mine is ~/FreePascal/default.cfg. Then each time I start a new project, I can go to the Run -> Compiler Options dialog (or Project -> Compiler Options), select Load/Save, and load my default.cfg file to the new project. You can, of course, modify the options for each new project if you so desire.

Mitwirkende und Änderungen

Diese Seite wurde von der epikwiki Version konvertiert.

  • Initially imported and formatted. VlxAdmin 9/22/2003
  • Changed Joe's part for Windows to require fpc 1.0.10. Vincent 9/25/2003
  • Updated "What is required for lazarus". AndrewJohnson 10/1/2003
  • Finished formatted the InstallingLazarus page VlxAdmin 2/22/2004
  • Posted some notes about Installing FPC and Lazarus: mostly reflecting experiences in trying to get the PATHS right in Linux. 3/11/2004 User:Kirkpatc
  • Copied the contents of my note into the main InstallingLazarus section, edited it slightly. I don't know how to remove the original note. 3/12/2004 User:Kirkpatc
  • Removed the original note. Tidied the wiki and formatting a bit. VlxAdmin
  • Corrected a couple of typos - 3/12/2004 User:Kirkpatc
  • Added link for daily snapshot deb packages - 3/27/2004 Vincent
  • Fixed links in GettingLazarus (downloading binaries) and several other pages. 22 July 2004 User:Kirkpatc
  • Added link for lazarus deb packages - 19 August 2004 VincentSnijders
  • Added a short note on installing in Debian - 23 Nov 2004 User:Kirkpatc
  • Considerable re-write and re-organization of installation section - 11 Dec 2004 User:Kirkpatc



Personal tools