Multiple Lazarus/de

From Free Pascal wiki
Jump to: navigation, search

Deutsch (de) English (en) español (es) français (fr) português (pt) русский (ru)

Mehrere Lazarus Instanzen

Sie können einen Ordner mit Lazarus auf ihrem Computer haben oder mehr. Diese Ordner können die gleichen oder unterschiedliche Versionen von Lazarus haben und unabhängig voneinander arbeiten (dazu der Abschnitt dealing with --primary-config-dir weiter unten). Sie brauchen Lazarus nicht mehrmals zu installieren, wenn Sie die gleichen Versionen haben möchten, weil das Konzept mehrerer Lazarus Ordner auf ihrem System "multiple Instanzen" in diesem Artikel heißt.
Für Linux lesen Sie dazu bitte DualLaz.

Wichtig

  • Machen Sie Backups von
    • Ihrer primary config (z.B. ~/.lazarus unter Unix)
    • Ihren Projekten *.lpi und *.lps

Wer braucht mehrere Lazarus Instanzen und wer nicht?

Sie brauchen mehrere Lazarus Instanzen...

  • um mehrere Lazerusversionen zu haben
  • um eine Lazarusversion mit mehreren verschieden FPCversionen kompilieren zu können

Sie brauchen nicht mehrere Lazarus Instanzen...

  • um ihr ProjeKt mit verschiedenen Widgetsets zu testen
  • zum Crosskompilieren

Der Lazarusordner

Der Lazarusordner (z.B. der Lazarus Programmordner) ist überschreibbar, wenn man --lazarusdir verwendet, was nützlich ist, wenn Lazarus z.B. von USBsticks an unterschiedlichen Mountpoint eingehängt wird oder unterschiedliche Laufwerksbuchstaben erhält.

Der Configordner

Alle IDE Einstellungen einer Instanz werden im Configordner gespeichert. Unter Linux, Mac OS X und BSD ist das üblicherweise der Ordner ~/.lazarus. Beachte den beginnenden Punkt, der ihn zu einem versteckten Ordner werden lässt.

Auf Windows, werden die Einstellungen im Benutzerverzeichnis, das je nach Windowsversion (und Sprache, in Windows XP und früher) woanders liegt. Lesen Sie bitte dazu auch folgende Information: Multiple Lazarus/de#Windows. Beachten Sie bitte, dass Sie das Konfigurationsverzeichnis erst sehen, wenn Sie unter Ordneroptionen versteckte und Systemdateien anzeigen aktiviert haben. Um das Verzeichnis anzuzeigen, tippe:

%localappdata%

in Start->Ausführen oder in die Adresszeile im Windows Explorer ein, was Sie ins Local Application Data bringen sollte. Für die erste Installation befinden sich die Einstellungen im dort angezeigten Lazarusordner.

Betriebssystem Üblicher Ort für den Configordner Bemerkungen
Linux, Mac OS X, BSD, other UNIXes ~/.lazarus verstecktes Verzeichnis
Windows XP C:\Documents and Settings\<User name>\Local Settings\Application Data\lazarus German Windows; andere haben verschiedentliche Pfade
Windows Vista und höhere C:\Benutzer\<Benutzername>\AppData\Local\lazarus\ Ungeachtet der gewählten Sprache

Der Configordner kann nicht unter verschieden Lazarusversionen geteilt werden. Eine neueres Lazarus kann ältere Configs lesen und diese automatisch updaten. Es gibt keine Garantie dafür, dass eine ältere Version Configdateien einer neueren Version lesen kann. Es ist immer eine gute Idee von Zeit zu Zeit ein Backup ihrer Configs zu machen, falls nun etwas sonderbar ist, nachdem Sie etwas geändert haben und Sie nicht wissen, was es war.

Lösung für verschiedene Instanzen, die mehrere Configordner benutzen

Der Configordner kann in der Kommandozeile mit dem --primary-config-path Parameter (kürzer: --pcp) angegeben werden. Beispielsweise

lazarus --primary-config-path=~/.lazarus2

startet eine IDE, die ~/.lazarus2 als Configordner benutzt. Auf diese Weise können Sie beliebig viele Configordner anlegen und unabhängige Lazarus Instanzen starten. Wenn Lazarus die Dateien mit den Einstellungen neu anlegt, können Sie, wenn Sie wollen, auch leere Verzeichnisse angeben.

Wenn Sie das öfter machen, können Sie sich dazu ein kleines Batchdatei anlegen:

#!/bin/sh
/path/to/lazarus --primary-config-path=~/.lazarus2

Unter Windows können Sie das nicht nutzen ~ stattdessen können Sie zum Beispiel eine Verknüpfung auf dem Desktop anlegen, um Lazarus mit den folgenden Parametern aufzurufen:

\path\to\lazarus.exe --primary-config-path=lazarusconf

Dies plaziert die Lazaruskonfiguration im Lazarusordner.

Mit der lazarus.cfg Datei

Ein anderer Weg den config Ordner zu setzen, ist dazu die Datei "lazarus.cfg" zu nutzen und sie im Ordner mit der Lazarus Ausführbaren zu legen und diese Zeile hinein zu schreiben :

--primary-config-path=\path\to\config\folder

Sie können auch einen config-Ordner im Lazarus Installationsverzeichnis anlegen und diesen Pfad in der cfg-Datei angeben. Danach wird Lazarus nun die lazarus.cfg Datei verwenden und man braucht kein Bashscript oder Verknüpfung mit Parameterangabe mehr.

Zum Beispiel sieht das für eine Installation unter Windows so aus: Ein config-Ordner und die lazarus.cfg Datei nahe der Lazarus Ausführbaren und setze einen Wert wie beispielsweise den folgenden in die cfg-Datei :

--primary-config-path=C:\Lazarus2\config\

Und starte Lazarus. Es wird nach einigen config-Werten gefragt und danach kann man eine einfache Verknüpfung ohne Parameter zur späteren Verwendung anlegen.

Dateien im Config-Ordner

lazarus.dci - hier speichert Lazarus Vorlagen

editoroptions.xml - Information zu Farben, Schrift und andere Editoroptionen

miscellaneousoptions.xml - Information zu Paketen

environmentoptions.xml - hier lagert die Chronik offener Projekte und Dateien(kürzlich geöffnete Dateien und Projekte)

Die Lazarusdateien

Das Lazarus Quellcodearchiv befindet sich in einem einzigen Verzeichnis. Sie können Lazarus einfach kompilieren (siehe Installationsanleitungen) und eine ganze Reihe Dateien und Unterverzeichnisse werden angelegt, aber alle befinden sich unter diesem Unterverzeichnis.

Eine Lazarus Instanz (Quellcode und Ressourcen) ist ein einziges Unterverzeichnis. Jetzt köönen Sie das Verzeichnis kopieren und Sie erhalten eine ganz neue Lazarusinstanz.

Sie brauchen Lazarus nicht zu installieren um es auszuführen zu können. Aber wenn sie Lazarus tatsächlich installiert haben, bekommen Sie schöne Verknüpfungen auf ihrem Desktop und einige Dateitypen (z.B. lpk, lpi, pas) werden mit dieser Lazarus Installation verknüpft. Diese Sachen sind unabhängig vom Betriebssystem. Es ist tatsächlich nie mehr als ein einziger Lazarus installiertund Zweitkopien sind eben "da".

Neuere Installer unterstützen es Lazarus mehrmals zu installieren. Alternativ können Sie auch eine andere Lazarus Instance manually sehr einfach hinzufügen. Natürlich können Dateiverknüpfungen, etc. nur mit einer einzigen Lazarus Instanz verknüpft werden.

Linux

Auf DualLaz findet sich eine Anleitung von 2015 für Linux 64 bit.

Beispiel 1 : Eine normal installierte Lazarus Instanz plus die Svnversion

Herunterladen und installieren der Lazarus debian- & .rpm - Pakete wie sonst auch.

Dann laden das Lazarus Svnarchiv in ein Verzeichnis ihrer Wahl herunter, vorzugsweise irgendwo in ihr home directory (z.B. ~/lazarus). Siehe hier Installing_Lazarus#Downloading_Lazarus_SVN.

Starten Sie ihren zweiten Lazarus mit:

/home/you/lazarus/startlazarus --pcp=~/.lazarus2nd

Beispiel 2 : Eine normal installierte Lazarus Instanz plus eine kopierte Version

z.B. Sie verschaffen sich zwei Unterverzeichnisse:

/usr/lib/lazarus     original  copy     via debian install
/home/you/lazarus    secondary copy 

oder Sie können dahin schauen:

/home/you/development/lazarus    original copy      via fpcUP install
/home/you/lazarus                secondary copy 

Herunterladen und installieren der Lazarus Debianpakete wie üblich.

Dann kopieren Sie den Lazarusordner in ihr home directory und ändern die Dateirechte:

cp -a /usr/lib/lazarus $(HOME)/
chown $USER:$USER -R $(HOME)/lazarus

(Beachte: Die chown Zeile nimmt an, dass ihre Gruppe den gleichen Namen wie ihr Benutzernamen hat. Wenn nicht, ersetzen Sie $USER:$USER mit ihrem Benutzernamen:Gruppenname)

Ändern Sie nun ihre Lazarus desktop/menu Verknüpfung um die zweite Kopie auszuführen

/home/you/lazarus/startlazarus --pcp=~/.lazarus2nd

Rufen Sie danach die IDE auf und ändern Sie die Umgebungseinstellungen: Werkzeuge -> Einstellungen ... -> Umgebung / Lazarusverzeichnis in das zweite Unterverzeichnis, namentlich /home/you/lazarus


In neueren Lazarusversionen gibt es zusätzlich ein Fenster um die anderen wichtigen Pfade zu benennen, so würden Sie das zweite Unterverzeichnis in die 2te Config umbenennen.

Ebenfalls im Verzeichnis befindet sich die /home/you/development/fpc/bin/x86_64-linux/fpc.cfg Textdatei, alle Pfade sollten ziemlich genau auf die zweite Kopie zeigen. Um sich zu vergewissern, dass alles gut ist, starten Sie startlazarus von xterm aus und beobachten die Fehlermeldungen. Vergewissern Sie sich, dass alle Pfade gefunden werden (gelegentlich sehr schwierig).


Sie haben nun eine zweite Kopie, die Sie bearbeiten und rekompilieren können. Vergessen Sie dabei nicht die Quelldateien der ersten /usr/lib/lazarus zu schließen.

Windows

Beispiel 1: SVN und Release

Das bedeutet, beide die SVNversion und das letzte Release von Lazarus zu haben.

1) Installiere das letzte Relaese von Lazarus und markieren Sie die Setupoption 'Desktop-Symbol erstellen' und Sie werden 'Lazarus.lnk' auf den Desktop bekommen.

2) Holen Sie Lazarus vom SVN und kompilieren Sie, danach legen Sie eine Verknüpfung zu 'lazarus.exe' auf ihren Desktop und benennen sie in 'Lazarus SVN.lnk' um.

Schließlich können das config dir für jede Version setzen, indem Sie den Pfad der Verknüpfung zur ausführbaren Datei bearbeiten:

Diese ist für das Release, weil Sie den primary config path Parameter nicht ändern, wird die Config wie üblich gespeichert:

C:\lazarus\startlazarus.exe

Für SVN speichern Sie die Einstellungen bitte z.B. im Ordner 'C:\lazsvncfg\' ab:

C:\FPC\laz\startlazarus.exe --primary-config-path=C:\lazsvncfg

Installation von multiplen Lazarus Instanzen

Windows - Mit dem Installer

Unter Windows kann der Installer (Version 1.1) eine secondary installation anlegen. Und er fragt nach einem Ordner um die Config aufzubewahren.

  • Installieren:
    • Vergewissern Sie sich, ein Backup aller ihren bestehenden Konfigurationen gemacht zu haben, BEVOR Sie installieren.
    • NOCHMALS: Vergewissern Sie sich, ein Backup aller ihren bestehenden Konfigurationen gemacht zu haben, BEVOR Sie installieren.
    • Nach dem Installieren prüfen Sie, ob die richtige Config benutzt wurde
      Sehe nach der Datei "lazarus.cfg" im Installationsordner. Und Menü "Ansicht" > "IDE Interna" > "Über die IDE"
    • Wenn Sie eine Nachricht über upgrading/downgrading der Config sehen, dann ist die Installation nicht korrekt verlaufen. Drücken Sie auf "Abbrechen"
  • Gebrauch
    • Teilen Sie keine Pakete zwischen den Installationen; vielmehr müssen Sie mehrere unabhängige Kopien für jedes Package haben
    • Machen Sie ein Backup der lpi- und lpsdateien (wenn Sie Projekte teilen). Idealerweise sichern Sie Sessions (lps) im "IDE config directory"
      Menü: "Projekt" > "Projekteinstellungen" > Session
  • Deinstallieren:
    • Wenn Sie deinstallieren wollen: legen Sie bitte wieder ein Backup von allem an
  • Update:
    • Wenn Sie updaten wollen: legen Sie bitte nochmals ein Backup von allem an
    • Nach dem Update prüfen Sie bitte, ob die noch korrekte Config benutzt wird
      Sehe nach der Datei "lazarus.cfg" im Installationsordner. Und Menü "Ansicht" > "IDE Interna" > "Über die IDE"

Der Windows Installer kann secondary installations anlegen, die es einem erlauben, unterschiedliche Versionen zu installieren, die einander nicht stören.

Alles was Sie tun müssen, ist einen Haken bei der Checkbox "secondary installation" setzen (wenn Sie das Installionsverzeichnis auswählen), und den Anweisungen zu folgen. Sie werden dann nach einen neuen leeren Ordner gefragt, wo die Config abgespeichert wird (das kann ein Unterordener im Installationsverzeichnis sein).

Wenn Sie eine Installation mit dem Windows Installer updaten, erkennt er, wenn das gewählte Verzeichnis eine zweite Installation enthält.

Um schnell erkennen zu können, welche IDE Sie benutzen, und um überprüfen zu können, ob die richtige Config geladen wurde, ist es ratsam einige sichtbare Kennzeichen zu ändern. Eine Möglichkeit besteht darin die GutterColor des Editors zu ändern.

Windows - Eine Installation zum Crosskompilieren hinzufügen

Die Installationspakete zum Crosskompilieren kann ebenfalls zur zweiten Installation hinzugefügt werden. Allerdings erhalten Sie zwischendurch eine Warnung, dasss der Ordner nicht leer ist. Diese Warnung kann übergangen werden.