MSEide & MSEgui/es

From Free Pascal wiki

English (en) español (es) Bahasa Indonesia (id)

Introducción

MSEide es un sistema de desarrollo gráfico (GUI) de plataforma cruzada orientado a programadores de Pascal. Está completamente escrito en Pascal. MSEgui no aporta compatibilidad con la librería de componentes visuales (VCL). La librería de gráficos aporta un interface con win32 y X11. Hay que tener en cuenta que es un proyecto fruto del esfuerzo en casi su totalidad de una persona (Martin Schreiber),

El IDE y GUI tienen un listado de muy buenas características:

  • La codificación de caracteres es UCS2.
  • Incluye utilidades de internalización.
  • Docking forms.
  • Embedded forms (similar to TFrame).
  • Visual form inheritance.
  • Enlaces a xlib y gdi32, no necesita de librerias de widgets externas.
  • Componentes de acceso a bases de datos y widgets de edición de datos.
  • Depuración integrada.
  • Integrated report designer.
  • Flexible and handy build system with switchable macros.
  • y más...

Pero, ¿que acerca de Lazarus?

Lazarus es un IDE que trata de aportar un alto grado de compatibilidad con código VCL, al tiemo que aporta un aspecto nativo en bastantes plataformas. La visualización nativa es muy importante para bastantes desarrolladores, pero combinada con la compatibilidad VCL hace necesarias interfaces complejas a los diferentes conjuntos de widgets nativos (GTK, Win32, Carbon, QT...). La continua evolución de este conjunto de widgets nativos (GTK1 -> GTK2, Win32 -> ?, , QT) conlleva un interminable conjunto de mantenimientos.

MSEide+MSEgui neither features (or suffers :-) de compatibilidad VCL, no provee un aspecto nativo en las plataformas objetivo. La librería de gráficos provee un interface a Win32 y X11. La ventaja de la capa X11 es la inmediata disponibilidad de un largo y estable conjnto de plataformas a lo largo del tiempo.

Estas diferentes finalidades de ambos proyecto hace que se adapten a las distintas necesidades de los programadores.

¿Porqué esta wiki?

El diseño de MSE GUI es una fresca aproximación a los patrones de diseño GUI. Aporta bastantes características innovadoras para tareas típicas de un inteface gráfico de usuario (GUI). Siendo innovador, la librería MSE GUI difiere sustancialmente de VCL/LCL/CLX. Pasar de VCL a MSE puede suponer mucho más cambio que cambiar desde VCL o LCL. Estas páginas de la wiki tratan de mostrar facilmente los primeros pasos con esta prometedora (IDE & GUI) librería alternativa.

Instalación

Quick start

Abriendo un proyecto

Lanza el IDE y utiliza Project->Open para abrir la demo de msegui/apps/demo/demo.prj. El título del IDE refleja el proyecto que hemos abierto. Pulsa F9 y (si has seguido las instrucciones de instalación correctamente :-), disfruta de la velocidad de FPC+MSE.

First RAD steps

Close the running project. Use Project->Source to open the project source demo.pas. Ctrl-click on the parameter mainfo in the line

application.createform(tmainfo,mainfo);

to navigate to main.pas. Click on F12 to toggle between unit and form. Not everything will feel that familiar, because of that, these pages are written. Click on the button, this will auto raise the property editor (unusual but usefull). Let us add another button. Make the component palette visible if necessary (View->Toolbar->Component Palette). Select the tbutton on the widget page. Click on the form to create the button. Give it a caption in the usual way. Creating an event handler does not work with the usual double clicking on the onexecute property. Instead, you must select the onexecute property in the property editor, type the name of an event handler and press enter. The MSE RAD will create the handler and position the pointer on the definition. Use ctrl-shift-down arrow (or up) to navigate between implementation and definition. Just add some code like writeln('Hello world'); Hit F9. The writeln will end up in the target console window of MSE (not the console in which you started MSE).

Adding a Main Menu

Add Main Menu

Add a tmainmenu component from the Gui component tab to your main form. Click on your mainform (mainfo), so that Object Inspector shows the properties of the mainform. Use the arrow next to the mainmenu property of the mainform, to select tmainmenu1 as the mainmenu of mainfo.

Add Menu Items

In the Object Inspector, expand the mainmenu branch. In this branch, open the menu property of mainmenu. Change the submenu.count of menu to 1 (or higher). Now expand the submenu.count property, which will show "Item 0". Expand "Item 0" and set the caption, for instance to "&File". Now you can repeat the same procedure one level deeper... Change the submenu.count property of "Item 0" to 1. Expand this last submenu.count property and set the caption of the new "Item 0", for instance to "E&xit". Hit F9 and your program should have a menu File with the entry Exit in it.

Alternatively, in Object Inspector you may right click a submenu.count property, or an "Item n" property, which will reveal a context sensitive pop up menu. Use this pop up menu to insert, append or delete menu items.

Once you have more than one submenu, you can use drag and drop to move the menu items ("Item n"). Start the drag mouse move on the "Item n" line.

Crear un nuevo proyecto

Para crear un nuevo projecto basado en una plantilla utilizar Project -> New > From Template. Para un nuevo proyecto GUI seleccionar "default.prj", y para un proyecto de consola seleccionar "console.prj".

El concepto

MSEgui es una librería de programa escrita en Pascal, aporta los bloques de construcción para el desarrollo de programas con interface gráfico de usuario.1

MSEide es el correspondiente entorno de desarrollo integrado (IDE) para la producción efectiva con Free Pascal y MSEgui. MSEide es también apropiado para el desarrollo de aplicaciones con gcc y microcontroladores.

Actualmente MSEide+MSEgui corre bajo i386-linux, x86-64-linux, arm-linux, x86-64-freebsd, i386-win32 y x86-64-win64 mientras que los microprocesadores soportados son CPU32, ARM and AVR32. MSEgui es predominantemente una plataforma independiente. Se pueden añadir plataformas adicionales implementando los elementos dependientes del sistema. Los módulos dependientes del sistema de MSEgui se encuentran ubicados en subdirectorios dentro de lib/common/kernel.

Principales finalidades del desarrollo

  • Una relevante incremento en la productividad. comparado con otros sistemas de desarrollo.
  • Idéntica apariencia y funcionalidad en todas las plataformas, sin adimentos medibles en el código de usuario.
  • La dependencia de librerias adicionales de mantiene al mínimo posible.
  • Ortogonalidad - debería haber la mínima interferencia posible entre los diferentes elementos de programa y tan pocos como sea posible a nivel de escepciones y casos especiales.
  • Elementos del interface gráfico de usuario (GUI) altamente parametrizados.
  • Trabajando con MSEide+MSEgui debería ser agradable.

Architecture overview

MSEgui no requiere de librerias de componentes externas - , se comunica directamente con el interface gráfico del sistema operativo. Con X11 a través de Xlib en Linux y con gdi32 bajo Windows.

Para los elementos individuales del GUI no se necesitan recursos adicionales del sistema operativo - únicamente las ventanas principales son conocidas pore el sistema operativo. El procesado completo de los eventos externos (teclado, ratón, control del foco, ...) tiene lugar dentro de MSEgui a nivel de Pascal.

La clase base para los elementos del GUI es un twidget. No hay distinción entre elementos gráficos simples y los que puedan recibir el foco, como es el caso en Delphi. Todos los widgets de MSEgui tienen a su disposición la funcionalidad completa de un twidget.


Importantes característica de un twidget son: twidget.frame y twidget.face. Cuando no se utilizan frame o face se representan mediante un puntero NIL, de forma que no consuma recursos.

twidget.frame es responsable del frame around del área de trabajo del elemento. La apariencia del frame es altamente ajustable - puede ser simle y rápidamente ser dibujable mediante un frame 3D, al tiempo que una compleja y lenta estructura basada en imágenes. Hay además otros elementos del frame que pueden construir barras de desplazamiento, pulsadores y etiquetas.

twidget.face dibuja el fondo del área de trabajo de un elemento del escritorio del GUI - de forma que se pueden mostrar gradientes de color e imágenes de maneras diferentes, mientras que se permite también una transparecia parcial.

Setting the properties of frame and face can be centralised by using tframecomp and tfacecomp, which can be selected into tframe and tface as templates.

The next level of centralization is tskincontroller, through which program-wide settings can be made. In order to achieve that, tskinkontroller assigns to the GUI elements the appropriate tframcomp and tfacecomp templates.

The control of the widget functions (focusin, focusout, ...) is done by virtual procedures and functions and not through messages. The MSEgui message function has other tasks. Also a Corba-style interface is used - for the safe connection between the various components and the automatic disconnection through destroy, a tobjectlinker is used.

The type msestring is used in MSEgui for storing text. At the moment, msestring equals WideString. However, the reference counted FPC WideString (UnicodeString) is planned to be used under Windows, as soon as it becomes available in one of the future FPC releases.

In text files the utf-8, ASCII or the local encoding is used - MSEide+MSEgui does not use utf-16 files.

The MSEgui database components provide the conversion from the local encoding or the utf-8 (adjustable) to WideString for the data buffering. For file operations, a set of MSEgui's own functions with WideString interface exists. An MSEgui application can therefore work consistently with WideStrings, which is a significant relief for some tasks.

Specialized data edit widgets for the basic data types (integer, real, tdatetime, ...) are available in MSEgui (tintegeredit, trealedit, tdatetimeedit, ...). The main event property of these widgets is onsetvalue, which can be used for reacting upon user input.

The t*edit widgets can be inserted into a twidgetgrid and in that way form a column of the appropriate data format.

For viewing and editing of data fields a tdbwidgetgrid togeather with a set of tdb*editwidgets can be used. Worth mentioning are also different lookup components and a tlookupbuffer, a fast associative data memory.

The basic component of the MSEgui's database environment is tmsebufdataset, from which tmsesqlquery is derived. MSEgui DB is a fork of the FPC SQLDB system, where TBufDataset and large parts of TSQLQuery and the connection components have been completely rewritten.

tmsebufdataset offers local indices, calculated and internalcalc-fields, a mode with an interrupted database connection, an in-memory mode where no database connectivity is necessary and can keep a local journal, in order to later reconect a previously disconnected database connection. tmsebufdataset stores texts as WideStrings of variable length.

Further, there are SQL script components and tsqlresult for quick queries without the TDataset overhead. Persistent TField instances are either kept within tmsesqlquery, where they can be edited in the object inspector via tmsesqlquery.controller.fields, or they can be inserted into forms or modules as as individual components from the 'DBf' component palette.

MSEide supports 'visual form inheritance', Submodule (Delphi TFrame equivalent) and allows the assignment of components of other forms or modules to component properties at design time.

Internationalization is done via resource modules that are loadable at runtime. The MSEi18n, a tool that supports the import and export of texts in spreadsheet programs is available for editing - therefore facilitating a translation by nonprogrammers.

1) This chapter is based on a translation of a German text provided by Martin Schreiber.

Tips: MSEide

Larger fonts

Some may find the standard menu font a bit small. The standard font for the main menu of an MSEgui application is the font defined by the stf_menu stock font. You can change a stock font value with a startup parameter, <fontheight> is given in pixels.

--FONTALIAS=<alias>,<fontname>[,<fontheight>[,<fontwidth>[,<options>]]]

So if you start the mseide like this, you can get a larger menu font:

 mseide --FONTALIAS=stf_menu,sans,16

In order to increase the base font size for all stock fonts use

 mseide --FONTALIAS=stf_default,,16

Shortcuts

Common

  • Ctrl+F4 - Close
  • Ctrl+S - Save
  • Ctrl+E - Select page
  • F11 - Toggle Form/Inspector
  • F12 - Toggle Form/Unit
  • Shift+Ctrl+[0..9] - Bookmark 0..9
  • Ctrl+[0..9] - Go to bookmark 0..9
  • Ctrl+LeftClick - Go to var(class, method, unit) declaration
  • Shift+Ctrl+Up - Go to method declaration
  • Shift+Ctrl+Down - Go to method implementation
  • Shift+Ctrl+Space - Show procedure header

Debug

  • F7 - Step
  • F8 - Next
  • F9 - Continue
  • Shift+F7 - Finish
  • Shift+Ctrl+F8 - Next instruction
  • Shift+Ctrl+F7 - Step instruction
  • F5 - Toggle breakpoint
  • Shift+F5 - Toggle breakpoint enabled/disabled
  • Ctrl+B - Breakpoints on/off
  • Ctrl+W - Watches on/off

Editor

  • Ctrl+Z - Undo
  • Ctrl+X - Cut
  • Ctrl+C - Copy
  • Ctrl+V - Paste
  • Ctrl+F - Find
  • F3 - Search again
  • Ctrl+L - Go to line.
  • Ctrl+I - Indent block
  • Ctrl+U - Unindent

Print from IDE

You need the ghostscript

Recent opened files or projects

The last opened projects are in the dropdown list of 'Project'-'Open'-'Name'. The last opened files are in the dropdown list of 'File'-'Open'-'Name'.

Menu Editing

  • Use submenu.count to set the wanted menu items count.
  • Right click on submenu.count or on a menu item "Item X" to display a context-sensitive menu that allows to insert,append or delete a submenu entry
  • Use drag and drop on a submenu entry to move the the item in the array.

New Panels in the IDE

Example, you want to have the watch, stack and cpu window in a window:

  • select the menu item View-Panels-New Panel.
  • select the menu item View-Watches.
  • drag the Watches window by the grip (not the window title!) in the new panel.
  • same with Stack and CPU window.
  • to split horizontal drag one of the grip of the inserted widgets to the left border of the panel.
  • to split vertical drag one of the grip of the inserted widgets to the bottom border of the panel.
  • to use tabs drag one of the grip of the inserted widgets to the centre of the panel.

Design Tab-Order

Main way in MSEide is set the tab order after all widgets are placed in the form with the popup menu function "Set Tab Order". Select a widget in the container where you wish to set the tab oder, click right, click "Set Tab Order", click row 0, click "Start", click the widget in the container which should get tab order 0, click the widget which should get tab order 1..

An alternative is to drag and drop the rows to the desired position. The first row corresponds to the tab order 0 the second to the 1 and so on.

Creating a new event handler

Select the event you want in the Object Inspector, then type name of the new event handler. IDE create a new procedure(declaration and implementation) in the source code. If you double-click the name of the event handler in the Object Inspector, source editor opens with the cursor at begin of your handler implementation.


Tips: MSEgui

Tabbed control

  • Put ttabwidget control on the form. Now you have container (ttabwidget1) for pages.
  • Put as many ttabpage controls on the ttabwidget1 as tabs you want.

Splitter

We have two widgets (widgetLeft, widgetRight) and we need horizontal splitter between them.

  • Add TSplitter to form and resize it as you want.
  • Change the linkleft of tsplitter1 to widgetLeft and linkright to widgetRight. At this step our widgets stick to splitter.
  • Change the spo_hmove to True. That's all.
  • If you want to save a proportion between width of widgetLeft and width of widgetRight when the main form is resized then change the so_hprop to True.
  • If you need the vertical splitter then use other properties linktop, linkbottom, spo_vmove, spo_vprop.

Switch-off auto-scrolling of the form(widget)

Change the container - frame - sbhorz - options - sbo_showauto property of the form to False.

Read/write data in the twidgetgrid

  • editwidget.value -> value of the actual row
  • editwidget[rowindex] or editwidget.gridvalue[rowindex] -> value of the addressed row
  • editwidget.gridvalues the whole column as a dynamic array.

First events

OnCreate is called before loaded procedures of the components of the form are called, OnLoaded is called after loaded procedures of the components of the form are called. Many components do initializations in loaded procedures, event properties are inactive before procedure loaded of the component is called.

MDI

MDI - application can be created using TDockFormWidget or TDockPanel (as MDI-area) and TDockForm (as ancestor for you MDI-child window). There are examples:

Drawing

Redraw form the additional thread

Use a tthreadcomp (tab Gui) to do the long time procedure. If you need to access widgets and other gui variables from the additional thread, call application.lock before and aplication.unlock after accessing the main event thread elements.

Force repaint

  • twidget.invalidate to invalidate an individual widget
  • twidget.rootwidget.invalidate to invalidate the window
  • application.invalidate to invalidate all windows (=forms) in the application

Draw text

There are two methods to draw texts in MSEgui:

  • Simple text positioning by baseline position of start of the first character with tcanvas.drawstring.
  • With the drawtext procedures of msedrawstring.pas.

Widgets canvas

No twidget has a canvas. The canvas used for painting is normally one of the canvas of twindow, it can also be an canvas of a tbitmap or a tprinter or... MSEgui uses one canvas to paint a whole window with all widgets. tcanvas.font is initialized by twidget.getfont, canvas.color by twidget.actualcolor before calling twidget.dopaint, see twidget.paint procedure in msegui.pas.

Theming (Frames & Faces)

Every twidget has a property frame and face. If they are deactivated (<disabled> in object inspector) they are only an nil pointer and need no more resources. Activate them by clicking on the ellipse button in the right object inspector column in the row face respective frame.

The face property defines the background of the client area of the widget.

It is a combination of a fade and a bitmap. Both of them can be semitransparent. The bitmap can be stretched and/or tiled. Example: you want to create a button with a fade as face.

  • place a tbutton on the form.
  • in object inspector activate property face.
  • set face.fade.color.count to 2.
  • click on the + at color.count.
  • in item 0 select cl_gray.
  • in item 1 select cl_ltgray, now you have a left to write fade from gray to light gray.
  • change face.fade.direction to gd_up or gd_down, you get a convex resp. concave fade.

If you want, you can blend an additional structure over the fade:

  • select the wanted pattern image in face.image.
  • activate face.image.alignment al_tiled.
  • adjust face.image.transparency to your needs, $000000 = opaque, $ffffff = fully transparent. The number defines the transparency of the three color channels ($RRGGBB).

To centralise the face look use an tfacecomp (tab Gui) and select the facecomp in template of the face properties.

The frame property defines the look of an additional frame around the component and shows a possible caption at the widget. Example: you want an lowered frame around and a caption right of the button.

  • activate property frame.
  • set frame.levelo to -1.
  • set frame.leveli to 1.
  • enter the caption text in frame.caption.
  • set frame.captionpos to cp_right.

To centralise the frame look use an tframecomp (tab Gui) and select the framecomp in template of the frame properties.

Desktop colors in the MSE application

Default values of the mapped colors stored in the array msegraphics.defaultmapped. For change it's values you can use function msegraphics.setcolormapvalue Win32 and KDE example ($MSESOURCES/contributed/miha/GuiStyle.pas)


Aplicaciones de ejemplo y pantallazos

Una aplicación utilizando Firebird

Los siguientes pantallazos se han tomado desde una aplicación de bases de datos con Firebird que utiliza MSEgui. El programador indica que ha personalizado el aspecto y comportamiento de su aplicación en unos 30 minutos utilizando un tfacecomp y dos tframecomp y ha constatado que el aspecto y comportamiento es idéntico tanto en Linux como en Windows.

mse dbwidgetgrid2.jpg

Versión utilizando Linux: mse form1.jpg

Versión utilizando Windows: mse form1w.jpg

Versión utilizando Linux: mse button1.jpg

Versión utilizando Windows: mse button1w.jpg

El reporte ha sido diseñado y renderizado con el diseñador y generador de reportes del MSEide+MSEgui embebido.

mse report1.jpg

Dos forumularios MDI con frame fade y flat.

mse gripfade1.png

Un sistema embebido

Un sistema embebido para aplicaciones médicas, en este caso esterilizadores steam, fue realizado con MSE-IDE & MSE-GUI con la unidad de conrol, nowadays además comunmente llamado "human machine interface", HMI.

Main Screen

La unidad de control utiliza un panel táctil como display, por lo que todos los controles activos necesitan ser suficientemente largos para que el personal pueda manejarlos a mano facilmente. La pantalla principal consiste de unos pocos campos informativos que permiten seleccionar los procesos de esterilizado por meido de un menú consistente en varios componentes pulsadores con sus correspondientes nombres descriptivos junto con una breve descripción de su funcionalidad en un panel separado. La visibilidad de los pulsadores y sus captions se definen durante la carga del programa mediante un fichero de configuración. Los campos informativos muestran los valores de operación de los dispositivos en tiempo real utilizando un timer de sistema MSE para recolectar la información desde un PLC.



Process Display

After processing has been started, the display is switched to a different format showing the operating values in large digits on some numeric display field components on the left and a graphical representation of the process history on the right, again both as real time "live displays". If the diagram curves would reach the right panel border, the diagram would change to a scrolling mode, always showing the current state at the extreme right.

State Display

For diagnostic purposes, also a schematic state display is available. This shows a simplified schematic of the apparatus, along with real time animated symbols of the control elements, as there are valves and pumps, each displayed in a derived version of a timage component, created and placed dynamically on program load. Also shown are the most important process values as numerical displays, also dynamically placed. The schematic field really is the output of a separate program, running in parallel to the process display which provides the upper and lower parts of the screen display.

Control Screen

There is also a mode for setting several control and function parameters and to recall previous operational and diagnostic data. It is organised as a tabbed screen containing several run time parametrized menu pages and a couple of display field pages. Some of the pages allow access only after entering a pass code to prevent missuse of critical functions.

Protocol Review

This is a screen displaying a graphical protocol of a previous process. The protocol is usually printed out immediately after termination, as required by the regulations. The printer output is generated as a postscript file, processed by ghostscript both for print out and for the on screen display shown, which uses the png format for loading into the display field.

Attribution

Of course, there is also an attribution display, showing program version, creator information and the tools used for the creation of the system, Free Pascal and MSE-IDE & MSE-GUI. As background, it uses a photography of one such apparatus as it is used in clinics displayed in an image component carrying several label fields used for the text. Above all of that sits a transparent button to close the picture.

Reference: MSEide

  • To move and resize components without gridsnap use shift+cursorkeys and ctrl+cursorkeys.
  • There are many possibilities with properties twidget.frame and twidget.face, for instance tiled semitransparent bitmaps and color fades (all twidget descendants have these properties!).

For client area of forms use tmseform.container.frame and tmseform.container.face, tmseform has additionally onpaint to do custom drawing.

You can write your own widgets and override procedure dopaint or use teventwidget with onpaint,onresize,onmouseevent,onkeydown,onkeyup...

How to convert filenames to windows format? 
Unit msefileutils: 
function tosysfilepath(const path: filenamety): filenamety; 
procedure tosysfilepath1(var path: filenamety); 
Converts to filename format of actual OS. 
function tomsefilepath(const path: filenamety): filenamety; 
procedure tomsefilepath1(var path: filenamety); 
Converts from filename format of actual OS.
Where is the MDI ???   
In MSEgui we have tdockform and tdockpanel for that purpose. 
Have a look at property dragdock.

MSEi18n

Reference: MSEgui

On this page you can find a working in progress for documenting MSEGUI.

External links

Website: http://mseide-msegui.sourceforge.net/

Community website: http://www.msegui.com

Unofficial incomplete help pages started from Z505 at: http://z505.com/cgi-bin/mse/idx.cgi?file=generalindex

Read the beginner's tutorial (in Russian) at: http://freepascal.ru/article/mse/20060108181639/

Also: "MSEide+MSEgui. Draw lesson." (in Russian) http://freepascal.ru/article/mse/20060205191314/

You can also find an English translation here: http://www.geocities.com/yetanothergeek/mseide-tutorial-en/

This page in Russian: http://freepascal.ru/wiki/index.php/MSEide%26MSEgui

MSElang, the future compiler for the MSEide+MSEgui project https://gitlab.com/mseide-msegui/mselang/wikis/home