Main menu/sk

From Lazarus wiki
Jump to navigationJump to search

Deutsch (de) English (en) español (es) suomi (fi) français (fr) magyar (hu) italiano (it) 日本語 (ja) македонски (mk) Nederlands (nl) português (pt) русский (ru) slovenčina (sk) shqip (sq) 中文(中国大陆)‎ (zh_CN) 中文(台灣)‎ (zh_TW)


Základné menu (Main Menu)

Riadok základného menu obsahuje nasledujúce položky:

File Edit Search View Project Run Components Tools Environment Windows Help

Ako je zvykom, položky môžu bať vybraté umiestnením myši nad položku menu a kliknutím ľavým tlačítkom myši alebo stlačením Alt-F na klávesnici (základné okno musí mať fokus, ak ho nemá stláčajte opakovane TAB na prepínanie fokusu medzi oknami, kým nie je titulkový pruh uíkladného okna zvýraznený farbou).

Menu File

FileMenu.png
  • New Unit: Vytvorí nový súbor jednotky (zdrojový kód Pascal).
  • New Form: Vytvorí nový formulár: vrátane pripojeného zdrojového súboru Pascal.
  • New ...: Poskytuje (pop-up menu box) s rôznymi typmi nových dokumentov.
  • Open: Otvorí dialóg pre otvorenie existujúceho súboru.
  • Revert: Ruší vykonané editácie a obnovuje súbor do pôvodného stavu.
  • Open Recent: Zoznam naposledy otvorených súborov.
  • Save: Uloží aktuálny súbor. Ak súbor ešte nemá meno, správa sa ako Save As.
  • Save As: Umožňuje vybrať adresár a meno pre uloženie aktuálneho súboru.
  • Save ALL:
  • Close: Zatvorí aktuálny súbor, spýtajúc sa na uloženie vykonaných úprav.
  • Close all editor files: Zatvorí všetky aktuálne otvorené súbory, spýtajúc sa na uloženie úprav.
  • Clean directory: Otvorí dialóg s nastaviteľnými filtrami, pre odstránenie súborov z aktuálneho adresára. Užitočné pre odstránenie súborov .bak a zvyškov projektov Delphi.
  • Print: Vytlačí zvolený súbor na tlačiarni systému. Táto položka menu sa predvolene neobjavuje, ale najprv je potrebné nainštalovať $Lazdir/components/printers/design/printers4lazide.pas a opäť preložiť IDE.
  • Restart:
  • Quit: Zatvorí Lazarus, spýtajúc sa na uloženie vykonaných úprav.

Menu Edit

EditMenu.png
  • Undo: Vrátenie poslednej editovanej akcie, ponechajúc Editor v stave tesne pred ňou.
  • Redo: Opakovanie poslednej akcie, ktorá bola vrátená pomocou Undo.
  • Cut: Vystrihne vybraný text a uiestni ho do schránky.
  • Copy: Prekopíruje vybratý text do schránky.
  • Paste: Vloží obsah schránky na pozíciu kurzora. Ak bol vybratý text, prepíše ho.
  • Indent selection: Posúva odsadenie vybratého textu doprava o rozsah zadaný v nastavení Environment -> Editor options -> General -> Block indent. Funkciaje užitočná pre formátovanie zdrojovéhokódu a vyvorenie blokovej štruktúry.
  • Unindent selection: Odstraňuje jednu úroveň odsadenia, posunúc text doľava o rozsah zadaný v nastavení Editora Block indent.
  • Enclose selection: Otvára pop-up menu s voľbami pre logické zakončenie vybratého textu (begin ... end; try ... except; try ... finally; repeat ... until; { ... } atď).
  • Uppercase selection: Konvertuje vybratý text na veľké písmená.
  • Lowercase selection: Konvertuje vybratý text na malé písmená.
  • Tabs to spaces in selection: Konveruje všetky tabulátory vybratého textu na medzery, podľa nastavenia Environment -> Editor options -> General -> Tab widths. Počet medzier nemá fixnú veľkosť, ale je to potrebný počet medzier na zaplnenie potrebnej šírky tabelátora medzerami.
  • Break lines in selection: Zalomí riadok vybratého textu, ktorý presahuje 80 znakov alebo počet zadaný v nastavení Environment -> Editor options -> Display -> Right Margin, riadok je zalomený na hranici slova a pokračuje na nasledujúcom riadku.
  • Comment selection: Vloží značky komentára // na každý riadok vybratého textu.
  • Uncomment selection: Odstráni značky komentára.
  • Sort selection: Zoradí riadky (alebo slová v odstavci) podľa abecedy; voľby pre smer radenia, citlivosť na veľkosť písmen. Uprostred zrojového kódu, samozrejme, to neprichádza do úvahy, ale ak máte zoznam, ktorý treba zoradiť, oceníte tento trik.
  • Select: Umožní výber blokov textu. Voľby zahŕňajú Vybrať všetko, vybrať po brace, vybrať odstavec alebo riadok, atď.
  • Insert from character map: Umožní vloženie symbolu, ktorý nie je na klávesnici, vybratý z pop-up mapy znakov.
  • Insert text: Zobrazí pop-up menu pre vloženie štandartných textov, ako kľúčové slová CVS (Author, Date, Header atď), či poznámku GPL, meno užívateľa, dátum a čas.
  • Complete code: Dokončí kód pod kurzorom. Závisí od kontextu a šetrí mnoho času. Napríklad dokončuje triedy, pridaním súkromných premenných, prístupové metódy Get a Set vlastností a pridaním tela metód. Na priradeniach premenných (tj. i:=3;) pridáva deklaráciu premennej. Pri forward deklarovaných procedúrach pridáva telá procedúr. Pri priradení udalostí (OnClick:=) pridáva definíciu a telo metódy. Viď Nástroje IDE Lazarus.
  • Extract procedure: Použije vybratý text (príkaz alebo sériu príkazov) na vytvorenie novej procedúry.

Menu Search

SearchMenu.png
  • Find: Obdoba vlastnosti skoro všetkých grafických editorov: pop-up dialógový box pre zadanie hľadaného textu a volieb hľadania, ako citlivosť na veľkosť písmen, celé slová, začiatok, oblasť a smer hľadania.
  • Find Next, Find previous: Pokračuje v hľadaní predtým zvoleného textu, zadaným smerom.
  • Find in files: Hľadá textový reťazec v súboroch: pop-up dialóg s voľbami všetky otvorené súbory, všetky súbory v projekte alebo všetky adresáre; umožňuje i zadanie masky pre výber typu súboru.
  • Replace: Podobné ako Find; zobrazí pop-up dialóg s miestom pre zadanie hľadaného reťazca a nahradzujúceho textu a volieb pre citlivosť na veľkosť písmen, smer atď.
  • Incremental find: Hľadanie reťazca kým zadávate hľadaný reťazec. Príklad: stlačíte "l" a je zvýraznené prvé "l", ak potom stlačíte "a", editor nájde nasledujúce "la" atď.
  • Goto line: Presunie kurzor na zadaný riadok súboru.
  • Jump back: Presunie kurzor späť k nasledujúcej záložke (musíte použiť Add jump point to history). Presúva i na záložky iných súborov otvorených v Editore.
  • Jump forward: Presunie kurzor vpred na nasledujúcu záložku.
  • Add jump point to history: Pridá do súboru záložky alebo skokové body.
  • View Jump-History: Ukáže zoznam záložiek v súbore: Zatiaľ neimplementované???.
  • Jump to next error, Jump to previous error: Skoč na na pozíciu nasledujúcej/predchádzajúcej hlásenej chyby v zdrojovom súbore.
  • Set a free bookmark: označ riadok, na ktorom je kurzor, ďalšou dostupnou (voľnou) číslovanou záložkou a pridaj ju do zoznamu záložiek. Pozor, vyskakovacie menu (získané kliknutím pravým tlačítkom myši na príslušný riadok zdrojového súboru) poskytuje väčší rozsah možností záložky, umožňujúc zadať číslo záložky, či skočiť na očíslovanú záložku, nie len na nasledujúcu/predchádzajúcu.
  • Jump to next bookmark, Jump to previous bookmark: Skoč na nasledujúcu/predchádzajúcu záložku v číselnom poradí.
  • Find other end of code block: Ak je kurzor umiestnený na begin, presunie kurzor na príslušný end a naopak.
  • Find code block start: Presunie kurzor na begin procedúry alebo funkcie, v tele ktorej je umiestnený.
  • Find Declaration at cursor: Presunie kurzor na miesto deklarácie zvoleného identifikátora. Môže to byť v rovnakom súbore alebo v inom. Ak nie je otvorený, otvorí ho v Editore (tak ak je procedúra alebo funkcia deklarovaná napr. v classesh.inc , tento bude otvorený v Editore).
  • Open filename at cursor: Otvorí súbor, ktorého meno je vybraté kurzorom. Užitočné na zobrazenie Include súborov alebo súborov obsahujúcich iné Jednotky použité v projekte.
  • Goto include directive: Ak je kurzor umiestnený v súbore, ktorý je Included v inom súbore, presunie kurzor na miesto v súbore, odkiaľ bol volaný súbor Include.
  • Find Identifier References: Poskytuje zoznam všetkých riadkov aktuálneho súboru, projektu alebo pripojených súborov, na ktorých je spomenutý identifikátor.
  • Rename Identifier: Umožňuje vývojárovi premenovať identifikátor. Pomocou vyskakovacie menu možno určiť, či sa má premenovanie vykonať len v aktuálnom súbore, v projekte, vo všetkých otvorených alebo pripojených súboroch atď. Dokoncá je možné premenovať aj identifikátory vyskytujúce sa v komentároch. Túto vlastnosť môžete využiť, napríklad, al prekladač hlási, že identifikátor už existuje, takže môžete potebovať nové meno svojho identifikátora.
  • Procedure List: Poskytuje zoznam všetkých procedúr a funkcií v aktuálnom súbore, spolu s číslom riadku, kde sú definované.

Menu View

Ovládanie zobrazenia rôznych okien a panelov na obrazovke.

ViewMenu.png
  • Object Inspector: Okno, zvyčajne umiestnené na ľavej strane obrazovky, ktoré zobrazuje funkcie formulára, ktorý je na obrazovke. Kliknutím myšou na ktorýkoľvek komponent formulára, spôsobí, že detaily komponentu budú zobrazené v Object Inspector. Na jeho vrchu je panel, ktorý zobrazuje stromovú štruktúru aktuálneho projektu a komponenty formulára môžu byť vybraté aj z tohoto panela. Základný panel má dve záložky, ktoré umožňujú zobraziť Properties alebo Events. Výber Properties zobrazí vlastnosti zvoleného komponentu v dvoch stĺpcoch, ľavý zobrazuje meno vlastnosti a pravý jej hodnotu. Výber Events zobrazí tiež dva stĺpce, ľavý s menom udalostí priradených ku komponentu a pravý ukazuje akciu, ktorá je výsledkom udalosti (procedúru udalosti). Ak nie je definovaná akcia, kliknutie na tlačítko
    ...
    spôsobí zobrazenie Editora zdrojového kódu s kurzorom umiestneným na prázdenj deklarácii procedúry, do ktorej môžete zadať svoj kód udalosti.
  • Source Editor: Základné okno pre editovanie zdrojového kódu. Jeho správanie je veľmi podobné iným grafickým editorom textu, takže môžete myšou presúvať kurzor nad zobrazeným textom a stlačenie ľavého tlačítka myši počas posúvania vyberie a označí text. Pravým kliknutím zobrazíte kontextové menu, ale ak ste zvyknutý na editory Windows, Gnome alebo KDE, budete márne hľadať zvyčajné funkcie, ako Vystrihnúť, Kopírovať a Vložiť, ale zahŕňa voľby ako Find Declaration alebo Open File at Cursor. Na vrchu okna Editora zdrojového kódu je niekoľko záložiek, reprezentujúcich otvorené súbory; kliknutie na jednu z nich vyvolá daný súbor do popredia, takto môžete jednoducho kopírovať zo súboru do súboru a vykonávať bežné editovacie funkcie. Editor zdrojového kódu poskytuje farebné zvýraznenie syntaxe kódu, s rôznymi farbami pre interpunkciu, komentáre, reťazcové konštanty atď. Rovnako zabezpečuje automatické odsadenie riadkov kódu. Funkcie a vzhľad Editora zdrojového kódu sú nastaviteľné cez menu Environment -> Editor options a zvolením jednej z viacerých záložiek.
  • Code Explorer: Okno, zvyčajne umiestnené na pravej strane pracovnej plochy, ktoré v stromovej forme zobrazuje štruktúru kódu aktuálnej jednotky alebo programu. Ak zmeníte súbor zobrazený v okne Editora zdrojového kódu, musíte zvoliť tlačítko Refresh na zobrazenie novej štruktúry súboru. Okno po otvorení zvyčajne zobrazuje meno jednotky a vetvy pre časti Interface a Implementation, ale kliknutím na
    +
    vľavo od vetvy otvoríte podvetvy a vetvičky :-), do úplných detailov samotných konštánt, typov a premenných, ako aj deklarácií procedúr a funkcií.
  • Units...: pop-up dialóg so zoznamom súborov jednotiek aktuálneho projektu, ktorý umožní vybrať súbor Zobrazený v Editore zdrojového kódu. Zaškrtnutím voľby Multi select môžete vybrať a otvoriť viac jednotiek naraz, ale len jedna bude zobrazená. Táto položka menu je lepšia ako položka Project -> Project Inspector, ale zobrazuje len zoznam jednotiek a dovoľuje ich otvoriť.
  • Forms...: pop-up dialóg so zoznamom formulárov aktuálneho projektu a umožní vybrať jeden alebo viac z nich pre zobrazenie.
  • View Unit Dependencies: pop-up dialóg, ktorý zobrazí stromovú štruktúru závislostí aktuálne otvorenej jednotky. Mnoho súborov zobrazených v tomto okne má svoje svoje vlastné
    +
    ,ktoré umožňujú preskúmať ich vlastné závislosti, často rekurzívnym spôsobom.
  • View Unit Information:
  • Toggle form / unit view F12: Prepína zobrazenie Formulár/Zdrojový kód formulára. Jednoduchším spôsobom je stlačenie F12 na klávesnici, ale táto položka menu má rovnaký význam.
  • Messages: Okno so správami prekladača, zobrazuje postup úspešného prekladu alebo vypisuje nájdené chyby.
  • Search Results: Okno s výsledkom hľadania textu v súboroch.
  • View Anchor Editor:
  • View Component Pallete:
  • View IDE Speed buttons:
  • Debug windows: pop-up menu s niekoľkými voľbami pre činnosť a konfiguráciu Debuggera. debugger je popísaný ďalej.

Menu Project

ProjectMenu.png
  • New Project: Vytvorí nový projekt a poskytuje možnosť zvoliť typ projektu.
  • New Project from file: Umožní vytvoriť nový projekt z existujúceho súboru.
  • Open Project: Otvorí projekt, ktorý už bol vytvorený a uložený. Dialóg ponúkne zoznam súborov Lazarus Project Information (.lpi), z ktorých si môžete vybrať.
  • Open Recent Project: Otvorí projekt zo zoznamu naposledy spracovávaných projektov.
  • Close Project:
  • Save Project: Obdoba File -> Save: uloží všetky súbory aktuálneho projektu; ak ešte neboli uložené, ponúkne dialóg na zadanie mena (ako Save Project As...).
  • Save Project As...: Požiada meno súboru pre uloženie projektu. Ponúkne prednastavené meno súboru Project1.lpi, ale môžete si zvoliť vlastné. Lazarus nedovoľuje použiť rovnaké meno súboru pre súbor projektu a súbor jednotky. Viz nižšie).
  • Publish Project: Vytvorí kópiu celého projektu. Bežný adresár projektu obsahuje veľa informácií, ktoré nie je potrebné publikovať (informácie o session, súbory .ppu, .o, .exe. Publish Project vytvorí súbor .lpi obsahujúci len základné informácie a do kópie presunie len zdrojové kódy, zo všetkych podadresárov. V dialógu môžete nastaviť filter exclude/include a spôsob kompresie výstupného archívu. Viz Nástroje IDE Lazarus
  • Project Inspector: pop-up dialóg so stromovou štruktúrou súborov aktuálneho projektu. Dovoľuje pridať, odstrániť alebo otvoriť zvolené súbory alebo zmeniť vlastnosti projektu.
  • Project Options...: pop-up dialóg s voľbami nastavenia projektu (titulok, meno cieľového súboru), Forms (dovoľuje výber z dostupných formulárov, a ich nastavenie Auto-create) a Info (určuje, či editačné informácie majú byť uložené pre zatvárané súbory, alebo len pre súbory projektu).
  • Compiler options ...: Konfigurácia prekladača, zahŕňa záložky: Paths definícia ciest hľadania jednotiek, include súborov, knižníc... ako aj voľbu pomocného typu formulára (gtk, gnome, win32); Parsing voľba pravidiel pre syntaktickú analýzu programov, Code voľby optimalizácie pre rýchlejšie alebo pomalšie programy, výber cieľového procesora, veľkosti haldy atď; Linking voľby použitia ladenia, statických alebo dynamických knižníc atď; Messages typy správ, generované pri výskyte chyby; Other určenie predvoleného konfiguračného súboru (fpc.cfg) alebo iného súboru; Inherited stromový diagram ukazujúci voľby zdedené z už zahrnutých jednotiek; Compilation dovoľuje zadať príkazy vykonávané pred/po spustení prekladača a použitie súborov Make.
  • Add editor file to Project: Do projektu pridá súbor, ktorý je práve upravovaný.
  • Remove from Project: pop-up menu na odstránenie súboru z projektu.
  • View Source: Bez ohľadu na to, ktorý súbor je práve upravovaný, zobrazí základný programový súbor (.dpr) alebo základný súbor .pas, ak .dpr neexistuje.

Menu Run

RunMenu.png
  • Build: Prekladá súbory projektu, ktoré boli zmenené od posledného prekladu.
  • Build all: Prekladá všetky súbory projektu, bez ohľadu na to, či boli alebo neboli zmenené.
  • Quick compile:
  • Abort build: Zastaví proces prekladu, ktorý je spustený - či už sa spamätáte, že máte niečo zle a chcete zastaviť preklad, alebo systém pracuje veľmi dlho a niečo je obvykle zle.
  • Run: Obvyklý spôsob spustenia prekladača a, ak je preklad úspešný, spustenia aplikácia. Lazarus uloží kópie súborov, potom spustí prekladač a linker, potom začne vykonávať finálny programový súbor (.exe).
  • Pause: Preruší vykonávanie aktuálne bežiaceho programu. Tým vám umožní skontrolovať akýkoľvek výstup, ktorý bol generovaný; vykonávanie môže pokračovať opätovným vybratím Run.
  • Step into: Used in conjunction with the debugger, causes execution of the program one step at a time up to a bookmarked point in the source.
  • Step over: Causes stepwise execution up to the statement marked, then skips the marked statement, and continues execution at normal speed. Useful in trying to isolate a statement that introduces a logical error.
  • Run to cursor: Spôsobí vykonávanie programu normálnou rýchlosťou (tj. nie jeden príkaz naraz) pokiaľ nedôjde po príkaz, na ktorom je umiestnený kurzor; potom zastaví. Pokračovanie vykonávania normálnou rýchlosťou dosiahnete zvolením Run.
  • Stop: Spôsobí zastavenie vykonávania bežiaceho programu. Nasledujúce zvolenie Run nepokračuje vo vykonávaní, ale spustí program od začiatku (ak treba i s prekladom).
  • Run Parameters: Otvorí viacstránkové pop-up okno, v ktorom môžete tadať voľby a parametre príkazového riadku pre spustenie programu; výber zobrazenia spusteného programu (tj. môžete použiť vzdialený X terminál terminal v Linuxe); môžete prepísať niektoré systémové premenné.
Veľmi zaujímavou možnosťou tohoto sub-menu je aktivácia okna terminálu pre zobrazenie vstupu/výstupu konvenčnej konzoly Pascalu. Ak pracujete na konzolovom programe Pascalu, (tj. nepoužijete pre program GUI s formulármi, tlačítkami...), potom môžete zaškrtnúť políčko "Use launching application". Keď to nastavíte prvý krát a skúsite sekvenciu Compile/Run, asi dostanete divoké hlásenie hovoriace
"xterm: Can't execvp /usr/share/lazarus//tools/runwait.sh: Permission denied".
Ak toto nastane, potrebujete zmeniť prístupové práva príslušného súboru; možno to budete musieť urobiť ako root (administrator). Po tomto, sa pri každom spustení programu objaví konzolové okno, v ktorom sa budú obajovať všetky vaše textové vstupy/výstupy (readln, writeln ...).
Po skončení práce vášho programu sa objaví na obrazovke správa "Press enter". Takto celý výstup generovaný vašim programom ostane na obrazovke, aby ste mali šancu prečítať si ho a okno bude zatvorené až po stlačení 'enter'.
Poznámka: keďže v aktuálnej verzii nie je pripravený príkaz konzoly pre používateľov Windows. Zatiať Lazarus team odkazuje, že musí pracovať nasledujúci príkaz (vo WinXP)
C:\Windows\system32\cmd.exe /C ${TargetCmdLine}
  • Reset debugger: Obnovuje debugger do jeho pôvodného stavu, všetky ladiace body a hodnoty premenných... sú zabudnuté.
  • Build file: Preloží súbor, ktorý je aktuálne otvorený v Editre zdrojového kódu.
  • Run file: Preloží, spojí a spustí aktuálne otvorený súbor.
  • Configure Build + Run File: Otvorí viacstránkové okno s voľbami, ktoré nastavia preklad práve tohoto súboru pri výbere Build Project, dovolia výber pracovného adresára, použitie rôznych makier... Potom preloží a spustí súbor.
Tieto posledné tri voľby umožňujú otvoriť (a spravovať) testovací projekt. Použite File -> Open pre otvorenie súboru .lpr a v nasledujúcom dialógu stlačte cancel pre otvorenie tohoto súboru ako "normálneho zdrojového" súboru.

Menu Components

  • Open Package: Zobrazí zoznam nainštalovaných balíčkov, s možnosťou otvoriť jeden alebo viac z nich, alebo výber rôznych všeobecných volieb alebo volieb prekladača.
  • Open Package File: Otvorí jeden zo súborov vo zvolenom balíčku.
  • Open package of current unit:
  • Open Recent Package: Ponúkne zoznam naposledy otvorených balíčkov.
  • Add Active Unit to Package: Pridá aktuálny súbor (otvorený v editore) do balíčka.
  • Package Graph: Zobrazí graf vzťahov jednotlivých balíčkov, ktoré sú používané (ak nepoužívate žiadny iný balíček, budú zobrazené balíčeky Lazarus, FCL a LCL).
  • Configure custom components: táto položka už nie je...

Menu Tools

ToolsMenu.png
  • Configure custom tools: Umožňuje užívateľovi pridať do nástrojov rôzne externé nástroje (zvyčajne makrá).
  • Project templates options:
  • Quick syntax check: Vykoná rýchlu kontrolu syntaxe vášho zdrojového kódu bez skutočného prekladu. Základný krok pri vývoji veľkých alebo komplikovaných programov, ak nechcete mrhať čas prekladom chybného kódu.
  • Guess unclosed block: Užitočný nástroj, ak máte zložitú alebo vnorenú blokovú štruktúru a chcete niekde nájsť end.
  • Guess misplaced IFDEF/ENDIF: Užitočné, ak ak máte zložitú alebo vnorenú štruktúru makra a potebujete nájsť direktívu ENDIF.
  • Make resource string: Z vybratého reťazca robí zdrojový reťazec (resource string) jeho umiestnením v sekcii resourcestrings. Výhodou zdrojových reťazcov je, že môžu byť zmenené bez poteby rekompilácie projektu!
  • Diff: Umožňuje porovnanie dvoch súborov (alebo dvoch verzií rovnakého súboru) a nájdenie rozdielov. Poskytuje voľby na ignorovanie prázdneho miesta na začiatku alebo konci riadkov alebo rôznych zakončení riadkov (CR+LF a LF). Užitočné na kontrolu, či boli urobené zmeny od poslednej aktualizácie CVS atd.
  • Check LFM file in editor: Umožňuje kontrolu súboru LFM, ktorý obsahuje nastavenia aktuálneho formulára.
  • Convert Delphi unit to Lazarus unit: Pomáha pri prenose aplikácií Delphi do Lazarus; robí potrebné zmeny v zdrojovom súbore. Viz Prechod z Delphi na Lazarus a Code Conversion Guide.
  • Convert DFM file to LFM: Pre prenos z Delphi do Lazarus. Konvertuje súbory Form Description z Delphi do Lazarus. Viz Prechod z Delphi na Lazarus and Code Conversion Guide.
  • Build Lazarus: Spúšťa znovuzostavenie Lazarus z naposledy stiahnutých alebo aktualizovaných súborov CVS (proces môžete sledovať v okne Messages).
  • Configure "Build Lazarus": Umožňuje určiť, ktoré časti Lazarus budú znova zostavené a ako. Napríklad, môžete nastaviť, že bude preložená len LCL alebo všetko okrem príkladov. Môžete nastaviť ktoré rozhranie LCL použiť a môžete nastaviť cieľový operačný systém, či nastaviť iný cieľový adresár.

Menu Environment

EnvironmentMenu.png
  • Environment options: viacstránkové okno so záložkami pre
    • Files - cesty k predvolenému adresáru, prekladaču, zdrojovému adresáru a dočasnému adresáru pre prekladanie;
    • Desktop - voľby pre jazyk, správanie automatického ukladania, ukladanie vlastností pracovnej plochy, hinty pre paletu komponentov a speed tlačítka;
    • Windows - zadanie veľkosti a správania rôznych okien;
    • Form Editor - výber farieb pre editovanie formulárov;
    • Object Inspector - výber farieb a veľkosti položiek;
    • Backup - udáva ako zálohovať súbory pri úpravách;
    • Naming - udáva príponu názvov súborov Pascalu ('.pp' alebo '.pas'), či sa majú ukladať malými písmenami, či vykonávať automatické mazanie alebo premenovanie.
  • Editor options: viacstránkové okno so záložkami pre
    • General - určuje správanie ako automatické odsadenie, zvýrazňovanie zátvoriek, drag-drop upravovanie, posúvanie, zvýrazňovanie syntaxe, zobrazovanie hintov, veľkosť odsadenia bloku a tabulátora, hranicu Undo;
    • Display - voľby pre zobrazovanie čísel riadkov, zobrazovanie guttera, veľkosť a typ fontu editora a okno so zobrazením farieb rôznych typov syntaxe, ako komentáre, značky, direktívy, chyby a ladiace body;
    • Key Mappings - voľby pre výber schémy Lazarus alebo Turbo Pascal;
    • Color - umožňuje nastaviť farebnú schému textu pre viac typov jazyka, ako Object Pascal, C++, Perl, HTML, XML a skripty shellu. Zobrazuje aj ukážkový panel (pre zvolený jazyk);
    • Code Tools - umožňuje výber funkcií ako Identifier Completion, tooltips, zadanie šablón názvov súborov, šablóny pre dokončovanie kódu.
  • Debugger Options: viacstránkové okno so záložkami pre
    • General - voľby debugera: bez, GNU debugger (gdb) alebo gdb cez SSH, zadanie vyhľadávacej cesty a volieb pre zvolený debugger;
    • Event log - nastavenie, či zmazať log pri spustení a ktoré správy zobrazovať;
    • Language Exceptions - výber výnimiek, ktoré budú ignorované;
    • OS Exceptions - umožňuje pridať isté signály, ktoré aplikuje na aktuálny operačný systém.
  • Code Tool Options: viacstránkové okno so záložkami pre
    • General - zadanie ďalších ciest pre hľadanie zdrojových súborov a určenie metódy Jumping Method;
    • Code Creation - určuje, či je vytváraný kód pridaný pred alebo za určitú funkciu;
    • Words - určuje, či sú kľúčové slová Pascal zadávané malými alebo veľkými písmenami, alebo s veľkými počiatočnými písmenami;
    • Line Splitting - zavádza pravidlá zalamovania riadkov (pred alebo po interpunkčných znamienkach, za kľúčovým slovom atď);
    • Space - určuje či sú medzery automaticky pridané alebo za určité syntaktické črty, ako kľúčové slová, alebo interpunkčné značky.
  • Code Tools Defines Editor:
  • Re-scan FPC Source directory Znova prechádza adresár. Lazarus používa zdrojové kódy FreePascal na generovanie správnych obslúh udalostí a pri hľadaní deklarácií. Ak niekto zmení adresár v nastavení prostredia, potom je tento adresár znova prehľadaný, aby bolo zaistené, že Lazarus používa verziu uchovanú v danom umiestnení. Ale ak bol tento adresár zmenený a Lazarus nebol o tom informovaný, potom sa môžu objaviť chyby pri navrhovaní formulárov alebo vykonaním "Find declaration". Ak sa stretnete s touto chybou, môžete urobiť dve veci:
    1. skontrolovať nastavenie zdrojového adresára vo voľbách prostredia.
    2. znova prehľadať zdrojový adresár FreePascal.

Menu Windows

Obsahuje zoznam aktuálne otvorených súborov a dostupných okien, ako Source Editor, Object Inspector, či Project Inspector. Kliknutím na názov jedného z okien je okno vyvolané do popredia a získava zameranie.

Menu Help

  • Online Help otvorí okno prehliadača so súborom c:/lazarus/docs/index.html, ktoré obsahuje obrázok bežiacej cheetah a niekoľko odkazov nafew links to the Lazarus, FreePascal and WiKi websites
  • Configure Help umožňuje nastaviť prehliadač a databázy, z ktorých budú čítané informácie nápovedy. Tieto voľby dovoľujú užívateľovi zadať jeden z on-line dokumentov na webovej stránke Lazarus-CCR, niektoré ďalšie webové stránky obsahujúce dokumenty, alebo lokálne umiestnenie dokumentácie. Predvolene, ak umiestnite kurzor nad kľúčové slovo FCL alebo RunTime Library (ale nie LCL) a potom stlačíte <<F1>> dostanete sa na príslušnú stránku.
  • About Lazarus Zobrazí pop-up box s informáciami o Lazarus.

Časom tu bude úplný on-line Help, s informáciami o syntaxe Pascalu, o použití IDE, o používaní, úpravách a tvorbe komponentov a tipy ako urobiť niektoré úlohy. Táto časť sekcie Dokumentácia (to čo teraz čítate) predstavuje začiatok procesu. Potrebujeme spolupracovníkov, ktorí sú ochotní pomôcť: Editácia WiKi je veľmo jednoduchá.