Difference between revisions of "Free Pascal"

From Lazarus wiki
(Lazarus and the Free Pascal Compiler: Not all Laz versions ever were compiled with FPC 2.6.0 see e.g. 0.9.28)
(Features)
Line 16: Line 16:
  
 
=== Features ===
 
=== Features ===
The language syntax is semantically compatible with TP 7.0 as well as most versions of Delphi (classes, rtti, exceptions, ansistrings). Furthermore Free Pascal supports function overloading, operator overloading and other such features.
+
The language syntax is semantically compatible with [[Turbo Pascal]] 7.0 as well as most versions of [[Delphi]] (classes, rtti, exceptions, ansistrings). Furthermore Free Pascal supports function overloading, operator overloading and other such features.
  
 
=== Requirements ===
 
=== Requirements ===

Revision as of 11:17, 18 February 2015

Deutsch (de) English (en) français (fr) 日本語 (ja) slovenčina (sk)

Lazarus and the Free Pascal Compiler

The recommended/required version of the Free Pascal Compiler for the Lazarus IDE depends from the Lazarus version:

  • Lazarus 1.0 up to 1.0.6: FPC 2.6.0
  • Lazarus 1.0.8 - 1.2.2: FPC 2.6.2
  • Lazarus 1.2.4 and newer: FPC 2.6.4

The recommended FPC version together with the matching Lazarus release can be found at the Lazarus sourceforge download area. FPC standalone releases can be found at the Free Pascal sourceforge site. Various source packages and binaries are available from these download sites.

From the Free Pascal Compiler website:

Overview

Free Pascal (aka FPK Pascal) is a 32 bit pascal compiler. It is available for different processors (Intel 80386 and compatibles and Motorola 680x0) and operating systems (Linux, FreeBSD, NetBSD, DOS, Win32, OS/2, BeOS, SunOS (Solaris), QNX and Classic Amiga).

Features

The language syntax is semantically compatible with Turbo Pascal 7.0 as well as most versions of Delphi (classes, rtti, exceptions, ansistrings). Furthermore Free Pascal supports function overloading, operator overloading and other such features.

Requirements

For the intel 80x86 version at least a 386 processor is required, but a 486 is recommended. For the motorola 680x0 version, a 68020 or later processor is recommended. In all cases, a minimum of 8 Megabytes of RAM is recommended, but the compiler is reported to work with 2 Megabytes of RAM.

License

The packages and runtime library come under a modified Library GNU Public License to allow the use of static libraries when creating applications. The compiler source itself comes under the GNU General Public License. The sources for both the compiler and runtime library are available; the complete compiler is written in Pascal.

Documentation

The Free Pascal Compiler documentation is available on this site or it can be found online and in a variety of downloadable formats on the main Free Pascal Compiler site.

Free Pascal Compiler Homepage