GDB Debugger Tips

From Lazarus wiki
Revision as of 13:21, 27 September 2012 by Martin (talk | contribs) (TimeOuts)

Introduction

Lazarus comes with GDB as default debugger.

Currently (Lazarus 0.9.30) not all features are implemented, and some things are not supported by GDB. Development is ongoing.

Below are a few of the existing issues (including workarounds where available), that can be encountered while using the debugger.

  • Note on GDB 7.5: GDB 7.5 is not supported by the released 1.0. Fixes to support it were made in 1.1.

See also

Setup

To get the best possible results, you must ensure that your IDE and Project are both correctly configured.

See Debugger Setup how to set up the IDE and your project in order to use the debugger.

Setup Video Tutorial

Other

Debugging console applications

General

Debug Info Type

When debugging 64 bit applications, it may be necessary to use dwarf.

Stabs

-g or -gs

You should only use if your gdb version does not support dwarf. There are very few other cases where you need it.

You may need it with "var param" (param by ref) procedure foo(var a: integer); However the IDE deals with this in 99% of all cases.

Dwarf

This is the recommended setting.

-gw

use with -godwarfsets if you have a recent gdb. Otherwise sets are not displayed correctly.

Differences

This list is in no way complete:

  • dwarf allows some properties (those directly mapped to a field)
  • stabs (and modern gdb) can do -gp (preserve the case of symbols, instead of getting the all caps stuff).
  • stabs has problems with some class type casts. The IDE fixes that in some cases. (Only affects gdb 7.0 and up) [1]

Inspecting Data-types (Watch/Hint)

Strings

If you inspect strings and wish to inspect individual chars by index (mystring[10]), then you must unfortunately specify the index 0-based. That is one less than you would normally: mystring[10-1]

This is because gdb thinks the index is 0-based. This problem will be fixed in some future release.

In 0.9.31 the IDE detects potential strings. But since it can't tell for sure if it looks at a string or pchar, it will display both results

Properties

Currently the debugger does not support any method execution. Therefore only properties that refer directly to a variable can be inspected.

TFoo = Class
private
  FBar: Integer;
  function GetValue: Integer;
public
  property Bar: Integer read FBar;        // Can be inspected
  property Value: Integer read GetValue;  // Can *not* be inspected
end;

Nested Procedures / Function

procedure SomeObject.Outer(NumText: string);
var 
  OuterVarInScope: Integer;

procedure Nested;
var 
  I: Integer;
begin
  WriteLn(OuterVarInScope);  
end;

var 
  OuterVarOutsideScope: Integer;

begin
  Nested;
end;

If you step into "Nested", then the IDE allows you to inspect variables from both stack-frames.

This is you can inspect: I, OuterVarInScope, NumText (without having to change the current stack frame, in the stack window)

However there are some caveats:

You can also inspect: OuterVarOutsideScope. That is against pascal scoping rules. This only matters, if you have several nested levels, and they all contain a variable of the same name, but the pascal scoping would hide the variable from the middle frame. Then you get to see the wrong value.

You can not evaluate statements across the 2 frames: "OuterVarnScope-I" does not work.

Variables treated as pointer (Objects/Dyn-Array/Var-Param...)

Sometimes Variables are pointers in GDB, where they are not in Pascal.

The IDE tries to correct this in many cases. If not you still have to fix it yourself. (One reasone why this might not be corrected by the IDE can be mixed stabs and dwarf debug info)

if you type SomeObject as a watch it may just say "TSomeClass 0x23ab76". Try typing SomeObject^

Arrays

Arrays are not always shown correctly. Furthermore the same type of array may be shown correctly if it is a global var, but not if it is a local var; or vice versa.

Sometimes it helps if there is a type name for the array

type 
  TIntArray = array of Integer;
var 
  x1: TIntArray;
  x2: array of Integer;

x1 may have better chances to be displayed correctly

Static Arrays

array [x..y] of Integer;

shows as chars, instead of int. Only gdb 7.2 or up seems to handle it correct.

Also some static array only show correct with fpc trunk, but not 2.4.2


Dynamic Arrays

Dynamic Arrays are internally pointers. This is not always recognized. Instead of

FooArray[1]

you may need to write

FooArray^[1]

(In 0.9.31, this is partly corrected)

Showing the entire array is not possible, and will either show a pointer, or empty


Windows

Error 193 (Error creating process / Exe not found)

For details see here. This issue has been observed under Win XP and appears to be a caused by Windows itself. The issue occurs if the path to your app has a space, and a 2nd path/file exists, with a name identical to the part of the path before the space. E.g.

Your app: C:\test folder\project1.exe
Some file: C:\test

SigSegV - even with new, empty application

Note
In most cases SigSegV is simply an error in your code.

The following applies only, if you get a SigSegv, even with a new empt application (empty form, and no modifications made to unit1).

A SigSegV sometimes can be caused by an incompatibility between GDB and some other products. It is not known if this is a GDB issue or caused by the other product. There is no indication that any of the products listed is in anyway at fault. The information provided may only apply to some versions of the named products:

Comodo firewall
http://forum.lazarus.freepascal.org/index.php/topic,7065.msg60621.html#msg60621
BitDefender
enable game mode

SigSegV - and continue debugging

http://sourceware.org/bugzilla/show_bug.cgi?id=10004

http://forum.lazarus.freepascal.org/index.php/topic,18121.msg101798.html#msg101798

gdb.exe has stopped working

GDB itself has crashed. This will be due to a bug in gdb, and may not be fixable in Lazarus. Still it may be worth submitting info (see section "Reporting Bugs" below). Maybe Lazarus can avoid calling the failing function.

There is one already known situation. GDB (6.6 to 7.4 (latest at the time of testing)) may crash while your app is being started. This happen while the libraries (DLL) for your app are loaded (watch the "Debug output" window). In this case go to the debugger options and in the field "debugger_startup_options" enter:

--eval-command="set auto-solib-add off"


"PC register is not available" ("SuspendThread failed. (winerr 5)")

GDB may fail with this message. This is due to http://sourceware.org/bugzilla/show_bug.cgi?id=14018 If you get this issue you may want to downgrade to gdb 7.2

Win 64 bit

  • Requires Lazarus 1.0 with fpc 2.6
  • Advised to use dwarf

Using 32 bit Lazarus on 64 bit Windows

Alternatively it should be possible to debug apps as 32 bit apps (using the 32bit version of gdb). Once successfully debugged the app can then be cross-compiled to 64 bit. (or a 2nd Lazarus installation can be used, but it must be ensured they use different configuration --primary-config-path option)

If installing the 32 bit Lazarus, ensure you change configuration so the correct fpc, and gdb are used.

-

See also http://forum.lazarus.freepascal.org/index.php/topic,13188.0/topicseen.html

Linux

Known Problems

There might be issues on at least some CPUs when using an old version of gdb (e.g. SPARC, with gdb 6.4 as supplied by Debian "Etch"). In particular, background threads might lock up even if the program appears to run correctly standalone.

Mac OSX

Under OSX you usually install GDB with the Apple developer tools. The version of GDB available at the time of writing this is 6.3.50

This section is a first approach to collect information about known issues and workarounds. The information provided here depends a lot on feedback from OSX users.

Known Problems

Debugging 32 bit app on 64 bit architecture

It is possible and maybe sometime necessary to debug a 32 bit exe on a 64 bit system.

This is only possible with Lazarus 0.9.29 rev 28640 and up. As of Dec 2010 this feature is relatively new, and little tested. You may experience problems.

Debug session freezes

  • This is for 0.9.30 and before - For 0.9.30.1, or 0.9.31 and later see "TimeOuts"

It appears that certain commands are not correctly (or incompletely) processed by gdb 6.3.50. GDB will not signal to the IDE that it finished the command, and the IDE will wait forever for gdb to return. Effectively your debug session becomes non-reactive. (Normally GDB finishes each command with a "<gdb>" prompt for the next command)

This has been observed with:

  • Certain Watch expressions (at least if the watched variable was not available in the current selected function)
  • [Fixed in rev 28640] 32 bit app on 64bit architecture raising an Exception

The only way to deal with this, is to define a time-out, and to assume if the time-out is reached, that the command indeed finished, and simply forgot to signal this fact. However it is impossible:

  • to predict how long a command really takes
  • to guarantee GDB will not later return some results from such a command
  • to guarantee that GDB's internal state is still valid

For those reasons this issue can not be properly fixed at current.

As a work around time-out have been added. To enable them recompile (use "make clean" to force the rebuild) the IDE with the following define: DBG_WITH_TIMEOUT ( -dDBG_WITH_TIMEOUT ) Please note:

  • There is no guarantee how well, or bad this works. You use that at your own risk. However a warning prompt will alert you if a time-out occurred
  • Time-outs have not yet been added to all functions. If you encounter uncaught time-outs (while having the define enabled), then please report them.

An alternative solution seems to be to use a newer version of GDB

In 0.9.31 timeout has become a configurable option. The define is no longer needed.

More info see her: http://bugs.freepascal.org/view.php?id=19262#c47944

TimeOuts

This is the same as the above "freeze" issue. Lazarus 0.9.30.1 and 0.9.31 are detecting the freeze (in all cases known at the time of writing this) and report it as timeout.

This is a Mac 64 bit issue

Configuration 0.9.30.1 and 0.9.31 and up only

In the options dialog (Tools Menu) under "Debugger general", there are "Debugger specific options" (only shown if gdb is selected as debugger).

Warn On Timeout
True/False. Auto continue, after a timeout, do not show a warning.
TimeOutForEval
Set in milliseconds, how long until a timeout detection is triggered (the detection itself may take some more time.)

You may need to "RESET" the debugger after those changes are made

As stated the timeout is due to a bug in GDB and can not be fixed in the IDE. It can not be guaranteed that GDB continues to function well. However, so far it seems that it always does. If timeouts cannot be avoided, then you may as well switch the warning off, and set the detection time low (250)

Hardware exceptions under Mac OS X

When a hardware exception occurs under Mac OS X, such as an invalid pointer access (SIGSEGV) or an integer division-by-zero on Intel processors, the debugger will catch this exception at the Mach level. Normally, the system translates these Mach exceptions into Unix-style signals where the FPC run time library handles them. The debugger is however unable to propagate Mach exceptions in this way.

The practical upshot is that it is impossible under Mac OS X to continue a program in the debugger once a hardware exception has been triggered. This is not FPC-specific, and cannot be fixed by us.

Using Alternative Debuggers

You can download GDB 7.1 (or later) from MacPorts

The following observations have been made:

  • MacPort GDB 7.1 seems to have issues with the stabs debug info from fpc.
Make sure you select "generate dwarf debug information (-gw)" on the linking tab of the project options
Watch out for the linker warnings about "unknown stabs"
If you still have problems ensure that no code at all, is compiled with stabs. Your LCL may contain stabs, and this will end up in your app, even if you compile the app with -gw. So you may have to recompile your LCL with -gw (or without any debug info). Same for any other unit, package, rtl, .... that may have stabs
  • MacPort GDB 7.1 seems to be unable to handle application-bundles. In order to debug your app, you must use "run param" to specify the actual executable inside the app-bundle ( project.app/Content/MacOs/project or similar)

Even with those rules followed, MacPort GDB does not always work with fpc compiled apps.


Those observations may be incomplete or wrong, please update them, if you have more information.

Links

  • Mac OS X comes with a lot of useful tools for debugging and profiling. Just start /Developer/Applications/Instruments.app and try them out.

Reporting Bugs

Check existing Reports

Please check each of the following links

Bugs in GDB

Create a new Report

If you have at any time in the past updated, changed, reinstalled your Lazarus then please check the "Options" dialog ("Environment" or "Tools" Menu) for the Version of GDB and FPC used. They may still point to old settings.

Basic Information

  • Your Operating system and Version
  • Your CPU (Intel, Power, ...) 32 or 64 bit
  • Version of
    • Lazarus (Latest Release or SVN revision) (Include setting used to recompile LCL, packages or IDE (if a custom compile Lazarus is used))
    • FPC, if different from default. Please check the "Options" dialog ("Environment" or "Tools" Menu)
    • GDB, please check the "Options" dialog ("Environment" or "Tools" Menu)
  • Compiler Settings: (Menu: "Project", "Project Options", indicate all settings you used )
    • Page "Code generation"
Optimization settings (-O???): Level (-O1 / ...) Other (-OR -Ou -Os) (Please always test with all optimizations disabled, and -O1)
  • Page "Linking"
Debug Info: (-g -gl -gw) (Please ensure that at least either -g or -gw is used)
Smart Link (-XX); This must be OFF
Strip Symbols (-Xs); This must be OFF

Log info for debug session

  • "Debug output"
Please open the "Debug output" window (from menu "View", "Debug windows").You must open this before you run your app (F9).
Run your app, with this window open, then once the error occurs, copy, zip, and attach the content of the "debug output" window
  • "Log file"
Start Lazarus with -debug-log option (you can do this for the same run as above):
On Windows
you need to create a shortcut to the Lazarus exe (like the one on Desktop) and edit it's properties. Add " --debug-log=C:\laz.log" to the command line.
On Linux
start Lazarus from a shell and append " --debug-log=/home/yourname/laz.log" to the command line
On Mac/OSX
start Lazarus from a shell /path/to/lazarus/lazarus.app/Content/MacOS/lazarus --debug-log=/path/to/yourfiles/laz.log
Attach the log file after reproducing the error.
    • Before 0.9.31: If possible, before producing the log file, please recompile the IDE with:
-dDBG_VERBOSE -dDBGMI_QUEUE_DEBUG
You need to use the option "clean all" to recompile.
    • 0.9.31 / 0.99 up
Add to the commandline:
--debug-enable=DBG_CMD_ECHO,DBG_STATE,DBG_DATA_MONITORS,DBGMI_QUEUE_DEBUG,DBGMI_TYPE_INFO