Difference between revisions of "IDE Window: Editor Options/de"

From Lazarus wiki
m (Einstellungen für Einrückung/Tabs)
m (Cursoreinstellungen)
Line 38: Line 38:
 
=== Cursoreinstellungen ===
 
=== Cursoreinstellungen ===
  
* X-Position des Cursors beibehalten: Beim Bewegen durch die Zeilen des Quellcodes wird die X-Position des Cursors beibehalten, solange das Zeilenende nicht überschritten wird.
+
* '''X-Position des Cursors beibehalten''': Beim Bewegen durch die Zeilen des Quellcodes wird die X-Position des Cursors beibehalten, solange das Zeilenende nicht überschritten wird.
* Persistenter Cursor: Keep caret blinking, even if loosing focus. The is needed on some systems, where the focus messages do not work properly.
+
* '''Persistenter Cursor''': Keep caret blinking, even if loosing focus. The is needed on some systems, where the focus messages do not work properly.
* Ständig sichtbarer Cursor: Move caret to be always visible when scrolling.
+
* '''Ständig sichtbarer Cursor''': Move caret to be always visible when scrolling.
* Über das Zeilenende hinaus scrollen: Allows the cursor to go past the last character into the white space at the end of a line.
+
* '''Über das Zeilenende hinaus scrollen''': Allows the cursor to go past the last character into the white space at the end of a line.
* Cursor überspringt Auswahl: When there is a selection and you press the left arrow, the cursor will go to the start of the selection.
+
* '''Cursor überspringt Auswahl''': When there is a selection and you press the left arrow, the cursor will go to the start of the selection.
* Cursor überspringt Tabulatoren:  
+
* '''Cursor überspringt Tabulatoren''':  
* Pos1-Taste springt zum nächsten Anfang: home key jumps to line start if nearer, similar to visual studio.
+
* '''Pos1-Taste springt zum nächsten Anfang''': home key jumps to line start if nearer, similar to visual studio.
* Ende-Taste springt zum nächsten Ende:
+
* '''Ende-Taste springt zum nächsten Ende''':
  
 
=== Auswahl ===
 
=== Auswahl ===

Revision as of 17:08, 21 June 2011

Deutsch (de) English (en) español (es) suomi (fi)

Der Dialog kann aufgerufen werden

  • im Hauptmenü unter Werkzeuge -> Einstellungen
  • im Kontextmenü des Quelltexteditors unter Editoreigenschaften


Allgemein

Einstellungen für Rücknahme

  • Rücknahme auch nach dem Speichern: Bewahrt die Undo-Liste beim Speichern.
  • Gruppenrücknahme: Bei der Rücknahme/ beim Wiederherstellen, werden alle ausständigen Änderungen der selben Art in einem Aufruf durchgeführt anstatt jede Änderung einzeln.
  • Rücknahmemaximum: Maximale Anzahl von Rücknahmeschritten.

Scrolleinstellungen

  • Über das Dateiende hinaus scrollen: Erlaubt es, den Cursor über die Dateiende-Markierung hinaus zu bewegen.
  • Halbseitiges Scrollen: Beim Scrollen mit Bild-hoch und Bild-ab wird nur eine halbe Seite weit bewegt.
  • Eine Zeile weniger scrollen: Erzwingt beim Scrollen eine Zeile weniger.
  • Scrollhinweise anzeugen:

Einstellungen für Einrückung/Tabs

  • Automatische Einrückung: Wenn neue Zeilen eingefügt werden (z.B. durch das Drücken der Enter Taste), wird der Editor den Cursor auf der neue Zeile mit der selben Anzahl von führenden Leerzeichen wie auf der vorhergehenden Zeile einrücken. Dies enthält auch "automatisches Ausrücken": Wenn die Einfügemarke hinter dem letzen Whitespace-Zeichen eines zusammenhängenden Blockes solcher Zeichen am Zeilenanfang steht, dann bewirkt das Drücken von Backspace ein Ausrücken. Dabei wird auf die Einrückung der vorigen Zeile geachtet. Enthält eine Zeile nur Leerzeichen, passiert dies nur , wenn die Einfügemarke am Zeilenende steht.
  • Tab rückt ganze Blöcke ein: Wenn aktiviert können mit <Tab> und <Shift><Tab> Blöcke eingerückt oder selektierter Text ausgerückt werden.
  • Blockeinrückung: Anzahl von Leerzeichen, um die ein Block eingerückt wird. Zum Beispiel mit Strg+I.
  • Intelligentes Einrücken: Wenn eingerückt wird, geht der Cursor zum nächsten Leerzeichen der vorherigen Zeile. Wenn die aktuelle Zeile länger ist als die vorhergehende, wird nach einer längeren Zeile davor gesucht.
  • Tabulatoren in Leerzeichen umwandeln: Beim Bearbeiten von Zeilen fügt der Editor Leerzeichen anstatt Tabulatoren ein. Der Rest der Zeile wird nicht geändert und Tabulatoren bleiben erhalten. Um alle Tabulatoren umzuwandeln markieren Sie die gesamte Datei (Strg-A) und gehen im Hauptmenü zu Bearbeiten -> Tabulatoren in Auswahl in Leerzeichen umwandeln.
  • Tab-Breite: Maximale Anzahl von Leerzeichen als Tabulatorersatz.


Dateien ablegen

Erlaubt dem Editor abgelegte Dateien zu akzeptieren.

Cursoreinstellungen

  • X-Position des Cursors beibehalten: Beim Bewegen durch die Zeilen des Quellcodes wird die X-Position des Cursors beibehalten, solange das Zeilenende nicht überschritten wird.
  • Persistenter Cursor: Keep caret blinking, even if loosing focus. The is needed on some systems, where the focus messages do not work properly.
  • Ständig sichtbarer Cursor: Move caret to be always visible when scrolling.
  • Über das Zeilenende hinaus scrollen: Allows the cursor to go past the last character into the white space at the end of a line.
  • Cursor überspringt Auswahl: When there is a selection and you press the left arrow, the cursor will go to the start of the selection.
  • Cursor überspringt Tabulatoren:
  • Pos1-Taste springt zum nächsten Anfang: home key jumps to line start if nearer, similar to visual studio.
  • Ende-Taste springt zum nächsten Ende:

Auswahl

  • Persistenter Block:
  • Block überschreiben:

Leistenhinweise zeigen

Zeigt Hinweise wenn sich die Maus über dem Rand befindet (die Leiste auf der linken Seite des Quelltext-Editors).

Verschiedenes

  • Sonderzeichen anzeigen: Leerzeichen werden als Punkte und ungültige Zeichen als Fragezeichen angezeigt.
  • Abschneiden von Leerzeichen am Zeilenende: Leerzeichen am Zeilenende werden abgeschnitten und nicht gespeichert. Dies trifft nur auf bearbeitete Zeilen zu.
  • Text am Cursor suchen: Wenn der 'Suche' Dialog aufgerufen wird, wird das Wort am Cursor genommen und in das Suchtext Feld eingetragen.
  • Ohne Markierung Wort kopieren: Wenn nichts ausgewählt ist und der Benutzer Kopieren (Ctrl-C) drückt, markiert der Editor das Wort und kopiert es. Das selbe gilt für Ausschneiden.
  • Kopieren/Einfügen mit Faltungsinformationen:


  • Leerzeichenbehandlung:
  • Reiterposition des Quell-Notebooks:

Anzeige

Auf dieser Seite lassen sich Einstellungen bezüglich der Ränder und der Schrift im Quelltexteditor treffen. Ein Vorschaufenster im unteren Bereich erlaubt einen Blick darauf, wie sich Änderungen auswirken.

Mit der Option Sichtbarer rechter Rand wird eine Linie am rechten Rand gezeichnet. Mit dieser Linie wird die Stelle angezeigt, ab der beim Ausdruck ein Zeilenumbruch erfolgt. Die Anzahl der Zeichen bis zur Trennlinie wird im folgenden Eingabefeld festgelegt. Vorgabe sind 80 Zeichen, was sich an früheren Zeiten orientiert, als es Editoren nur im Textmodus gab. Da auf modernen Monitoren deutlich mehr als 80 Zeichen in einer Zeile dargestellt werden können, hat die Option keine Auswirkung auf die Darstellung am Monitor. Soll die Farbe der Linie geändert werden, so führt ein Klick auf den Link zur Seite mit den Farbeinstellungen.

Eine Leiste am linken Rand läßt sich mit Sichtbare Randleiste einschalten. Diese Leiste wird zur Darstellung zusätzlicher Informationen wie Zeilennummern oder Haltepunkte benötigt.

Da sich Fehlermeldungen oft auf eine bestimmte Zeilennummer beziehen, lassen sich die Ursachen schneller finden, wenn die Anzeige der Zeilennummern aktiviert ist. Da die Anzeige der Zeilennummern in der linken Randleiste erfolgt, muß die Anzeige der Randleiste ebenfalls aktiviert sein. Da die Nummerierung einer jeden Zeile bei einer Suche nicht unbedingt übersichtlich ist, läßt sich die Anzeige auf jede n-te Zeile einschränken.


Da die richtige Schriftart im Editor die Lesbarkeit verbessern kann, bietet auch Lazarus verschiedene Einstellmöglichkeiten. Die Schriftart kann einfach sein wie 'courier' oder kompliziert wie '-adobe-courier-medium-r-normal-*-*-140-*-*-*-*-iso10646-1' unter GTK/X. Weiterhin läßt sich die Schriftgröße ändern sowie ein zusätzlicher Abstand zwischen Zeilen und auch den Zeichen einrichten. Der zusätzliche Abstand wird in Pixeln angegeben. Mit dem Abschalten des Antialiasing läßt sich auf leistungsschwächeren Systemen die Belastung veringern, um Fehlern bei der Darstellung vorzubeugen.

Farben

Auf dieser Seite können die Farbeinstellungen für die Syntaxhervorhebung in der IDE vorgenommen werden. Der Haupt-Hervorheber ist derjenige für Object Pascal. Alle anderen Hervorheber nutzen dessen Farben als Vorgabeeinstellung.

Die Buttons und Comboboxen am oberen Rand bieten die folgenden Funktionen:

  • Syntaxhervorhebung nutzen: Bei Deaktivierung dieser Funktion bleiben die anderen Einstellungen ohne Auswirkung.
  • Sprache: Hier läßt sich der Hervorheber für eine bestimmte Sprache wählen. Voreingestellt ist Object Pascal. Zur Auswahl stehen aber z.B. auch C++ oder Python.
  • Farbschema: Die IDE enthält einige vordefinierte Farbschemata (z.B. für die von Turbo Pascal bekannten Farben). Es empfiehlt sich, erst ein Farbschema zu wählen, bevor einzelne Elemente bearbeitet werden.
  • Dateiendungen: Hier lassen sich die Dateitypen einschränken, für welche die Hervorhebung gelten soll.
  • Export: Bietet die Möglichkeit, die getroffenen Einstellungen in eine XML-Datei zu sichern.
  • Alle Elemente auf Voreinstellungen setzen: Wenn man sich bei der Einstellung der Farben total vertan hat, dann bietet sich hier eine schnelle Möglichkeit, den Ausgangszustand wiederherzustellen.

Es folgen zwei Fenster, in denen sich einzelne Elemente auswählen und die getroffenen Änderungen in einer Vorschau betrachten lassen.

Im Bereich Elementattribute läßt sich festlegen, ob globale oder lokale Schema-Einstellungen verwendet werden sollen. Außerdem kann man hier einzelne Elemente auf ihre Voreinstellung zurücksetzen. Mit der Wahl von Vorder- und Hintergundfarbe läßt sich jedem Element eine individuelle Note geben. Dabei sollte beachtet werden, daß nicht jede mögliche Farbkombination auch sinnvoll ist.

Markup and Matches

Klammerhervorhebung

Wenn der Cursor hinter oder vor einer Klammer ist, hebt es die zugehörige Klammer hervor.

Tastaturbelegung

Siehe Lazarus IDE Shortcuts.

Filter

At the top there is an edit field to set a text filter. You can type some letters and the tree will be updated to show only those keys which description contains the word. Set empty to show all.

Tree of IDE shortcuts

Hier können Sie alle Kommandos und shortcuts der IDE sehen. Klicken Sie auf einen der Schlüssel, um einen Dialog erscheinen zu lassen, zum Bearbeiten des shortcuts.

Find key combination

Click on the button to show a dialog. Grab a key and press ok. The tree will then only show those keys that start with the shortcut. Select VK_UNKNOWN to show all.

Schema auswählen

Lädt eine der vordefinierten Tastaturbelegungen. This will replace all your shortcuts.

Konsistenz überprüfen

Sucht nach doppelt definierten Tasten

Maus

Diese Seite ist ein Teil der Online-Hilfe für die IDE.
Sie beschreibt den Abschnitt: "Editor" / "Maus". Sie können diesen Dialog in Ihrer IDE aufrufen über:

  • das Menü: Werkzeuge => Einstellungen -> Editor -> Maus ...
  • das Kontextmenü des Quelltexteditors (Rechtsklick): -> Einstellungen ...

Navigation

     
  • IDE Options Überblick über alle Einstellungen der IDE


Allgemein

Maus beim Tippen verbergen

Wenn der Mauszeiger über einem Editor ist, wird er während Sie tippen verborgen. Jede Mausbewegung, Mausklick oder Menübefehl machen ihn wieder sichtbar.

Randleiste

Sie können aktuell zwischen zwei vordefinierten Modi für die Randleiste wählen:

Standard

Alle Klicks mit der linken Maustaste auf die Randleiste reagieren, wenn die Maustaste gedrückt wird.

Erweitert

Alle Klicks mit der linken Maustaste auf die Randleiste reagieren, wenn die Maustaste losgelassen wird. Dieser Modus erlaubt es, mit der Maus Text zu markieren und trotzdem eine Klickaktion auszulösen.

  • Maus gedrückt und bewegt (zu einer anderen Zeile oder in den Textbereich hinein), erstellt eine Auswahl. Beim Auslassen erfolgt keine Aktion.
  • Maus gedrückt und ausgelassen ohne Bewegung, führt den normalen Randleistenklick aus (Breakpoint / Codefaltung)

Text

Alt-Taste aktiviert Spaltenmodus

Erlaubt die spaltenweise Auswahl. Halten Sie die Alt-Taste gedrückt, während Sie mit der Maus Text auswählen.

Auswahl verschieben

Mit der linken Maustaste ziehen Sie eine Auswahl an eine neue Stelle. Bei zusätzlicher Strg-Taste wird die Auswahl kopiert.

Rechte Maustaste bewegt auch den Cursor

DIe rechte Maustaste zeigt immer das Kontextmenü an. Die Einfügemarke auf die Klickposition zu setzen ist optional.

Doppelklick markiert Zeile

Normalerweise wählt ein Doppelklick ein Wort aus, ein Dreifachklick eine Zeile (ohne führende und nachfolgende Leerzeichen). Mit dieser Einstellung wählt der Doppelklick die Zeile aus, ein Dreifachklick schließt auch führende/nachfolgende Leerzeichen ein.

Mittlere Taste

"Auswahl einfügen": Bei einer aktiven Auswahl wird eine Kopie an der angeklickten Position eingefügt.

Strg + linke Taste

Als Vorgabe: Wenn Sie auf einen Bezeichner (wie z.B. eine Funktion, eine Variable oder einen Typnamen) klicken, springt die IDE zur Deklaration dieses Bezeichners (sogar in eine andere Unit hinein).

Dieses Merkmal ist auch als Tastenkürzel verfügbar (üblicherweise Alt+. Siehe "Einstellungen" / "Tastaturbelegung" / "CodeTools-Befehle" / "Deklaration suchen"

"zum anderen Blockende" bedeutet: Wenn Sie nicht auf einem Bezeichner sondern auf einem Blockanfang sind ("begin", "end" oder einem Klammerpaar oder etwas Ähnlichem), dann erfolgt ein Sprung zum passenden Wort / zur passenden Klammer. Auf der Tastatur ist das Strg+Q+K, siehe: "Tastaturbelegung" / "Codetools-Befehle" / "Anderes Blockende suchen".

Erweitert

Für erweiterte Einstellungen sehen Sie bitte hier: Erweiterte Maus-Einstellungen

Wenn Sie in den erweiterten Einstellungen Änderungen vorgenommen haben, zeigt diese Seite einen Hinweis darauf.

In diesem Fall werden Ihre Änderungen nicht mehr sofort vorgenommen. Stattdessen wird ein Knopf angezeigt, der Sie zum Überschreiben der Einstellungen mit Ihren Änderungen auffordert. Falls Sie ungespeicherte Änderungen haben, wird ein Warnhinweis angezeigt.

Erweitert

Automatische Funktionen

  • Leere Methoden automatisch entfernen:
  • Blöcke vervollständigen: Wenn Sie z.B. begin eingeben und die Enter Taste drücken, dann fügt die IDE ein end; hinzu. Dieses Feature gibt es seit Version 0.9.27.
  • Deklarations-Hinweise anzeigen:
  • Werte-Hinweise während des Debuggens anzeigen:
  • Verzögerung für Hinweise:
  • Verzögerung für lange Zeilenhinweise:
  • Lange Zeilenhinweise anzeigen:

Codefaltung

Codefaltung: (De)Aktiviert die Codefaltung

Reverse fold-order in popup

Unter Sprache läßt sich auswählen, für welche Dokumente in der unterhalb folgenden Liste die Einstellung der Codefaltung vorgenommen werden kann. Zu Auswahl stehen:

  • ObjectPascal Dateien
  • HTML Dokumente
  • XML Dokumente
  • Lazarus Formulardateien
  • Diff-Dateien

Trennlinien

In diesem Bereich läßt sich festlegen, ob im Quelltexteditor horizontale Trennlinien gezeichnet werden. Mit diesen Linien lassen sich z.B. zusammengehörige Bereiche im Quelltext besser hervorheben.

Unter Sprache kann einstellt werden, für welche Art von Dateien die Festlegung der Trennlinien erfolgen soll. Derzeit steht nur ObjectPascal zur Verfügung. In der darunter folgenden Liste können die Bereiche ausgewählt werden, um die eine Trennlinie gezeichnet werden soll. Man sollte sich aber im Klaren darüber sein, daß zuviele Trennlinien zu lasten der Lesbarkeit gehen. Bei Bedarf können den Trennlinien auch abweichende Farben zugewiesen werden.

Seiten und Fenster

Schliessen-Schaltfläche im Notebook anzeigen

Zeigt einen Schliessen-Button auf jeder Seite im Quelltexteditor. Nicht alle Widgetsets unterstützen dies (im Moment nur die Gtk, Gtk2 und Qt Schnittstelle).