Difference between revisions of "IDE tricks/ja"

From Lazarus wiki
(IDE macros)
(Getting the compiler command line parameters created by the IDE)
Line 11: Line 11:
 
[[IDE Macros in paths and filenames/ja]]
 
[[IDE Macros in paths and filenames/ja]]
  
= Getting the compiler command line parameters created by the IDE =
+
= IDEが作成したコマンドラインパラメータをコンパイラで取得する方法 =
  
You can copy the parameters from Project -> Compiler Options -> Show Options. Here the paths are relative to the project directory. So in most cases you can copy them without adjusting.
+
Project -> Compiler Options -> Show Options でパラメータをコピーすることができます。ここに、プロジェクトディレクトリまでの相対パスがあります。多くの場合、調整することなく、これをコピーして使うことが出来ます。
  
The parameters are also saved to the *.compiled file. For example if your project is called test1.lpi, then a test1.compiled is created. It is a simple text xml file, so you can just copy the options and adjust the paths to compile on another computer. The file is put into the same directory, where the executable is created.
+
これらのパラメータは *.compiled ファイルにも保存されます。たとえば、test1.lpiというプロジェクトに対しては、test1.compiledというファイルが生成されます。これは、単純なテキストのxmlファイルになっていて、オプションやパスを簡単に他のコンピュータにコピーすることができます。
 +
このファイルは実行ファイルが作成されるのと同じディレクトリにおかれます。
  
For packages this works the same.
+
パッケージも同じ仕組みになっています。
  
This way, you can compile your (hopefully working and bugfree) code, outside of the lazarus IDE.
+
このように、lazarus IDEがなくても、(願わくばバグがなく、動く)コードをコンパイルすることができます。
  
 
= Closing all editor files except one =
 
= Closing all editor files except one =

Revision as of 15:24, 7 November 2006

Deutsch (de) English (en) français (fr) magyar (hu) 日本語 (ja) 한국어 (ko) русский (ru) slovenčina (sk)

Open file で新しいファイルを作る

新しいファイルをつくって、保存することができます。または、1回の操作で新しいファイルをファイル名とファイルタイプを指定して、作成することもできます。

ただ、open file (Ctrl+o)で、存在しないファイルを指定します。たとえば、unit1.pasを指定すると、IDEはそのファイルを作るかどうか、尋ねます。

IDE マクロ

IDE Macros in paths and filenames/ja

IDEが作成したコマンドラインパラメータをコンパイラで取得する方法

Project -> Compiler Options -> Show Options でパラメータをコピーすることができます。ここに、プロジェクトディレクトリまでの相対パスがあります。多くの場合、調整することなく、これをコピーして使うことが出来ます。

これらのパラメータは *.compiled ファイルにも保存されます。たとえば、test1.lpiというプロジェクトに対しては、test1.compiledというファイルが生成されます。これは、単純なテキストのxmlファイルになっていて、オプションやパスを簡単に他のコンピュータにコピーすることができます。 このファイルは実行ファイルが作成されるのと同じディレクトリにおかれます。

パッケージも同じ仕組みになっています。

このように、lazarus IDEがなくても、(願わくばバグがなく、動く)コードをコンパイルすることができます。

Closing all editor files except one

Under gtk (available for linux, macosx and freebsd) the source editor pages have a close button right to their page name. Press the Ctrl key while clicking on the button, closes all files except the clicked one.

Component palette

Finding a component in the palette

You know the component name, or part of it, but you don't know in which page it was? This tool finds it: Right click on a component in the palette to open the popup menu. Choose 'Find component'. Type part of the name to filter the list.

Open the package of a component in the palette

Right click on the component to open the popup menu, then choose open package.

Find the source declaration of a component in the palette

Right click on the component to open the popup menu, then choose open unit.

My application freeze my linux desktop while debugging

X (your desktop) can freeze, when an application that grabbed the mouse is stopped by gdb (the debugger).

Using a second X session

You can start a second X by:

  X :1 &

with Ctrl-Alt-F7 you switch to :0 and with Ctrl-Alt-F8 you switch to :1 after that you can start a second gnome session by:

  gnome-session --display=:1 &

Using VNC

You can use vncserver/client by installing tightvncserver/realvncserver Start the server with:

  vncserver :1

AFAIK, a session is also started. You can connect to the vncserver with vncviewer.

Debug the application on the second server

In lazarus, in the run parameters for your project, check "use display" and enter

 :1

Now your application will run on the second server, so when it is being debugged, only the second server will freeze (but that won't affect you since you are debugging on the first).

Compiling the IDE fast

Working on Lazarus itself needs rebuilding the IDE many times. If you use the following tricks and have enough memory and a recent cpu, you should be able to recompile the IDE in a few seconds.

  • Put the Lazarus sources on a fast harddisk. Not on a slow network filesystem.
  • Install only needed packages.
  • Set USESVN2REVISIONINC=0 to skip the update of the revision.inc.
  • Compile only parts. If the packager registration is recompiled, then all installed packages are recompiled too. If the IDEIntf is recompiled, then all installed design-time packages are recompiled.
  • Under windows: use the internal linker

Finding the source file of a IDE window

  • Open the IDE window.
  • Press Ctrl+Shift+F1 to open the help editor.
  • Remember the window classname. Close the window.
  • Use 'Find In Files' to find the source file of the class.