Difference between revisions of "Nomenclature/de"

From Lazarus wiki
m
 
(5 intermediate revisions by 2 users not shown)
Line 7: Line 7:
 
* die Methodennamen "DoFoo" sind reserviert zum Aufruf der Ereignisse "OnFoo"
 
* die Methodennamen "DoFoo" sind reserviert zum Aufruf der Ereignisse "OnFoo"
 
* Vorschlag: benutzen Sie "UpdateFoo" anstelle von "DoSetFoo" um bestimmte Werte zu aktualisieren oder um Zuweisungen zu validieren
 
* Vorschlag: benutzen Sie "UpdateFoo" anstelle von "DoSetFoo" um bestimmte Werte zu aktualisieren oder um Zuweisungen zu validieren
* Ereigniseigenschaften sollten mit "On...." benannt werden, beginnend mit einem Adjektiv, dann einem Verb, dann einem Nomen (einige sind optional),<br>
+
* Ereigniseigenschaften sollten mit "On...." benannt werden, beginnend mit einem Adjektiv, dann einem Verb, dann einem Nomen (einige sind optional), wie: OnFilterRecord, OnPostError, OnDblClick (zuerst das Adjektiv zum Verb)
wie: OnFilterRecord, OnPostError, OnDblClick (zuerst das Adjektiv zum Verb)
 
 
* Benachrichtigungen für Nachfahren von TControl sollten 'CNxxx' genannt werden
 
* Benachrichtigungen für Nachfahren von TControl sollten 'CNxxx' genannt werden

Latest revision as of 09:49, 5 July 2015

Deutsch (de) English (en) español (es) français (fr) 日本語 (ja) 한국어 (ko) português (pt) русский (ru)

  • Eigenschaften sollten nicht mit einem Verb, sondern mit einem Nomen beginnen
  • Methoden sollten mit einem Verb beginnen
  • die Methodennamen "GetFoo" sind reserviert für die Getter der Eigenschaft "Foo"
  • die Methodennamen "SetFoo" sind reserviert für die Setter der Eigenschaft "Foo"
  • die Methodennamen "DoFoo" sind reserviert zum Aufruf der Ereignisse "OnFoo"
  • Vorschlag: benutzen Sie "UpdateFoo" anstelle von "DoSetFoo" um bestimmte Werte zu aktualisieren oder um Zuweisungen zu validieren
  • Ereigniseigenschaften sollten mit "On...." benannt werden, beginnend mit einem Adjektiv, dann einem Verb, dann einem Nomen (einige sind optional), wie: OnFilterRecord, OnPostError, OnDblClick (zuerst das Adjektiv zum Verb)
  • Benachrichtigungen für Nachfahren von TControl sollten 'CNxxx' genannt werden