Lazarus Tutorial

From Lazarus wiki
Revision as of 11:11, 17 February 2005 by Vincent (talk | contribs) (The Button bar)

The Lazarus IDE: A Tutorial

This is the start of a Lazarus Tutorial. Please feel free to add your experiences to it.

Overview

Lazarus is a free and open source development tool for the FreePascal Compiler (object pascal), which is also free and open source. The Lazarus IDE (screenshot) is a stable and feature rich programming environment for creating self-standing graphical and console applications. It currently runs on Linux, FreeBSD and Win32 and provides a customizable source editor and visual form creation environment along with a package manager, debugger and complete GUI integration with the FreePascal Compiler.

Getting Started - Your first Lazarus Program!

(Thanks to User:Kirkpatc)

Get, install (Installing Lazarus) and launch Lazarus which will also make available the FreePascal Compiler.

Several windows will appear on the desktop: the main menu at the top, the Object Inspector on the left, the Lazarus Source Editor occupying most of the desktop, and a ready-made Form1 window overlying the Source Editor.

On the top Menu window, underneath the menu line, is a row of tabs. If the 'Standard' tab is not already selected, select it by clicking with the mouse. Then find the Button icon (a rectangle with 'OK' on it) and click on that with the mouse. Then double-click on the Form1 window, somewhere to the left of the middle. A shadowed rectangle labelled 'Button1' will appear. Click again on the Button icon in the Standard tab, and double-click on the Form1 somewhere to the right of centre: a rectangle labelled 'Button2' will appear.

Now click on Button1 to select it. The Object Inspector will display the properties of the object Button1. Near the top is a property named 'Caption', with the displayed value 'Button1'. Click on that box, and change 'Button1' to 'Press'. If you hit ENTER or click in another box, you will see the label of the first button on Form1 change to 'Press'. Now click on the Events tab on the Object Inspector, to see the various events that can be associated with the button. These include OnClick, OnEnter, OnExit etc. Select the box to the right of OnClick: a smaller box with three dots (... ellipsis) appears. When you click on this, you are taken automatically into the Source Editor and your cursor will be placed in a piece of code starting:

 procedure TForm1.Button1Click(Sender: TObject);
 begin
   {now type:}    Button1.caption := 'Press again';
   {the editor has already completed the procedure with}
 end;

Press F12 to select the Form1 window instead of the Source Editor.

Now edit the properties of Button2: click on Button2 to display its properties in the Object Inspector. Change its Caption property to 'Exit' instead of 'Button2'. Now select the Events tab, and click on the box for OnClick. Click on the ... ellipsis, and you will be taken into the Source Editor, in the middle of another procedure:

 procedure TForm1.Button2Click(Sender: TObject);
 begin
 {now type:}   Close;
 {the editor has already completed the procedure with} 
 end;

Now Press F12 to see the Form1 window again. You are now ready to try to compile. The simplest way to do this is to select 'Run' from the main menu at the top, and then the 'Run' option on the sub-menu. Alternatively you could simply type F9. This will first compile and then (if all is well) link and execute your program.

Several text windows will appear and all sorts of compiler messages will be typed, but eventually your Form1 window will re-appear, but without the grid of dots; this is the actual main window of your application, and it is waiting for you to push buttons or otherwise interact with it.

Try clicking on the button labelled 'Press'. You will notice that it changes to 'Press again'. If you press it again, it will still say 'Press again'!!

Now click on the button marked 'Exit'. The window will close and the program will exit. The original Form1 window with the grid of dots will reappear, ready to accept more editing activity.

You should save your work now (and frequently!!) by selecting Project > Save As > your_selected_file_name.pas

SECOND SESSION.

Re-open your saved Project. On the Form1 window click on the 'Press' button (Button1) to select it. Select the 'Events' tab on the Object Inspector, click on the right side box next to OnClick, click on the ... ellipsis, to go back to the appropriate point in the Source Editor.

Edit your code to read as follows:

 procedure TForm1.Button1Click(Sender: TObject);
{Makes use of the Tag property, setting it to either 0 or 1}
 begin
   if Button1.tag =0 then
   begin
     Button1.caption := 'Press again';
     Button1.tag := 1
   end else
   begin
     Button1.caption := 'Press';
     Button1.tag := 0
   end
 end;

Save your work, re-compile and run. The left button will now toggle between two alternative messages.

The rest is up to you!

If you prefer to write Console- or text-based Pascal programs (for example if you are following a basic Pascal programming course, or you need to write programs to use in batch mode or for system programming), you can still use Lazarus to edit, compile and run your programs. It make an ideal environment for Pascal development. See Console Mode Pascal.

The Editor

When you launch Lazarus for the first time, a series of separate disconnected or 'floating' windows will appear on your desk-top.

The first, running right along the top of the desk-top, is titled Lazarus Editor vXXXXXX - project1 (which will subsequently be modified to reflect the name of your currently-open project). This is the main controlling window for your project, and contains the Main Menu and the Component Palette.

http://lazarus-ccr.sourceforge.net/kbdata/lazmain.jpg

On the line below the title bar is the Main Menu with the usual entries for File, Edit, Search, View functions and so on, with a few selections that are specific to Lazarus. Below this on the left is a set of BitButtons (which take you rapidly to particular Main Menu options) and on the right is the Component Palette.

Under the Lazarus Editor window will appear the [http:../kbdata/objinsp.jpg Object Inspector] window on the left, and the [http:../kbdata/editor.jpg Lazarus Source Editor] on the right. There may be another smaller window, labelled [http:../kbdata/blankform.jpg Form1], overlying the Lazarus Source Editor window. If this is not visible immediately, it can be made to appear by pressing the F12 key, which toggles between the Source Editor view and the Form view. The Form window is the one on which you will construct the graphical interface for your application, while the Source Editor is the window which displays the Pascal code associated with the application which you are developing. The operation of the Object Inspector is discussed in more detail below while the Component Palette is described.

When you start a new project (or when you first launch Lazarus) a default Form will be constructed, which consists of a box in which there is a grid of dots to help you to position the various components of the form, and a bar along the top which contains the usual Minimise, Maximise and Close buttons. If you click with your mouse cursor anywhere in this box, you will see the properties of this form displayed in the Object Inspector on the left side of the desk-top.

Other windows that may become visible during your work: the [http:../kbdata/projinsp.jpg Project Inspector], which contains details of the files included in your project, and allows you to add files to or delete files from your project; the Messages window, which displays compiler messages, errors or progress reports on your project; if Lazarus was launched from a terminal window, the original terminal remains visible and detailed compiler messages are also printed there.


The Main Menu

The main menu line contains the following entries: File Edit Search View Project Run Components Tools Environment Windows Help

As usual, the options can be selected either by placing the mouse cursor over the menu option and clicking the left mouse button, or by typing Alt-F on the keyboard (provided the main menu window has focus: if it has not, hit TAB repeatedly to cycle focus through the various windows until the desired window has its title bar highlighted in colour).

The File sub-menu

  • New Unit: Creates a new Unit file (Pascal Source).
  • New Form: Creates a new Form: both the visual on-screen window and the associated Pascal source file.
  • New ...: Offers a pop-up menu box ([http:../../kbdata/menu-new.jpg screenshot]) with a variety of new document types to create.
  • Open: Offers a pop-up Dialog Box to enable you to navigate the filesystem and choose an existing file to open.
  • Revert: Abandon editing changes and restore the file to its original state.
  • Save: Save the current file, using its original filename. If there is no name, the system will prompt for one (just like Save As).
  • Save As: Allows you to choose a directory and filename for saving the current file.
  • Close: Closes the current file, prompting wheter to save all editor changes.
  • Close all editor files: Close all files currently open in the editor. Prompt for saving changes.
  • Clean directory: Offers a dialog with a series of editable filters for removing files from the current directory. Useful for removing .bak files and remnants of former Delphi projects.
  • Quit: Exit Lazarus, after prompting for saving all edited files.

The Edit sub-menu

  • Undo: Undo the last edit action, leaving the Editor in the state just before the last action.
  • Redo: Re-instates the last action that was reversed by Undo.
  • Cut: Remove the selected text or other item and place it on the Clipboard.
  • Copy: Make a copy of the selected text, leaving the original in place, and placing the copy on the Clipboard.
  • Paste: Places the contents of the Clipboard at the cursor position. If text has been selected at the cursor position, the contents of the Clipboard will replace the selected text.
  • Indent selection: Move the selected text to the right by the amount specified in Environment -> Editor options -> General -> Block indent. This feature is useful for formatting your Pascal source code to show the underlying Block structure.
  • Unindent selection: Removes one level of indenting, moving the text to the left by the amount specified in Block indent.
  • Enclose selection: Provides a pop-up menu with a number of options for logically enclosing the selected text (begin ... end; try ... except; try ... finally; repeat ... until; { ... } etc).
  • Uppercase selection: Convert selected text to uppercase.
  • Lowercase selection: Convert selected text to lowercase.
  • Tabs to spaces in selection: Converts any tabs in the selected text to the number of spaces specified by Environment -> Editor options -> General -> Tab widths. The number of spaces is not a fixed quantity, but is the number needed to fill the remaining width of the tab.
  • Break lines in selection: If any lines in the selected text are longer than 80 characters or the number specified in Environment -> Editor options -> Display -> Right Margin, then the line is broken at a word boundary and continued on the next line.
  • Comment selection: Makes the selected text into comments by inserting // on each line.
  • Uncomment selection: Removes comment marks.
  • Sort selection: Sort lines (or words or paragraphs) alphabetically; options for ascending or descending order, case sensitive or insensitive. In the middle of program source code, of course, it makes no sense, but if you have a list you need to have sorted this will do the trick.
  • Select: Allows selection of blocks of text. Options include select all, select to brace, select paragraph or line etc.
  • Insert from character map: Allows insertion of non-keyboard symbols such as accented characters, picked from a pop-up character map.
  • Insert text: Displays pop-up menu to allow insertion of standard text such as CVS keywords (Author, Date, Header etc) or GPL notice, username or Current date and time.
  • Complete code: Completes the code at the cursor. It is context sensitive and saves you a lot of time. For example: it completes classes, by adding private variables, Get and Set property access methods and adding method bodies. On variable assignments (e.g. i:=3;) it adds the variable declarations. On forward defined procedures it adds the procedure bodies. On event assignments (OnClick:=) it adds the method definition and the method body. See Lazarus IDE Tools.
  • Extract procedure: Uses the selected text (a statement or series of statements) to build a new procedure.

The Search sub-menu

  • Find: Similar to the facility in almost all graphic text editors: a pop-up dialog box appears allowing entry of a search text string, with options such as case sensitivity, whole words, origin, scope and direction of search.
  • Find Next, Find previous: Search again for the previously entered text string, in the specified direction.
  • Find in files: Search for text string in files: pop-up dialog with options all open files, all files in project, or all directories; masks available for selecting file types.
  • Replace: Similar to Find; shows pop-up dialog with place to enter search text string and replacement text, and options for case sensitivity, direction etc.
  • Incremental find: Search for the string while you are entering the search string. Example: after you choose "Incremental Find" if you press "l" the first "l" will be highlighted. If then you press "a", the editor will find the next "la" and so on.
  • Goto line: Move editing cursor to specified line in file.
  • Jump back: Move back in file to next Bookmark (need to have used Add jump point to history). Will move to Bookmarks in other files open in the Editor.
  • Jump forward: Move forward to next Bookmark.
  • Add jump point to history: Add Bookmarks or jump points to file.
  • View Jump-History: Look at list of bookmarks in file: Not implemented yet.
  • Find other end of code block: If positioned on a begin, finds the corresponding end or vice versa.
  • Find code block start: Moves to the begin of the procedure or function in which the cursor is placed.
  • Find Declaration at cursor: Finds the place at which the selected identifier is declared. This may be in the same file or another file already open in the Editor; if the file is not open, it will be opened (so if a procedure or function is declared, for example, in classesh.inc , this will be opened in the Editor).
  • Open filename at cursor: Opens the file whose name is selected at the cursor. Useful for looking at Include files or the files containing other Units used in the project.
  • Goto include directive: If the cursor is positioned in a file which is Included in another file, goes to the place in the other file that called the Include file.

The View sub-menu

Controls the display of various windows and panels on the screen.

  • Object Inspector: The window that usually occupies the left side of the Desktop, and displays the features of the Form which is on the desktop. Clicking with the mouse on any component of the form will cause the details of that component to be displayed in the Object Inspector. There is a panel at the top which shows the tree-structure of the current project, and the components of the form may optionally be selected in this panel: this will also cause the corresponding details to be displayed in the Object Inspector. The main lower panel has two tabs which allow selection of either Properties or Events to be displayed. Selection of Properties causes features such as name, colour, caption, font, size etc to be displayed: there are two columns, the left showing the property, and the right showing the value associated with that property. Selection of Events displays two columns: the left lists the possible events such as MouseClick or KeyDown associated with that component, and the right shows the action that results from that event. If there is no action defined, then clicking in the appropriate box or on the ... button causes the Source Editor to be displayed, with the cursor already positioned in a dummy Procedure declaration, waiting for event-defining code to be typed in.
  • Source Editor: The main window in which source code is edited. Its behaviour is very like that of most other graphical text editors, so that the mouse can move the cursor over the displayed text, and clicking with the left mouse button while dragging the mouse will select and highlight text. Right clicking with the mouse displays a pop-up menu, but if you are familiar with Windows, Gnome or KDE editors, you will find that the pop-up menu DOES NOT include the usual Edit Cut, Copy or Paste functions, but does include options like Find Declaration or Open File at Cursor. The top of the Source Editor window has a number of tabs, corresponding to the files that are open for the current project; clicking on any tab makes that file visible, and you can move easily from file to file, copying and pasting between files and performing most of the normal editing functions. The Source Editor performs colour syntax highlighting on the code, with different colours for punctuation marks, comments, string constants etc. It will also maintain the level of indentation from line to line as you type in code, until you change the indentation. The function and appearance of the Source Editor are very configurable from the Main Menu by selecting Environment -> Editor options and then selecting one of several tabs in the pop-up dialog box.
  • Code Explorer: A window usually placed on the right of the Desktop which displays, in tree form, the structure of the code in the current unit or program. It usually opens with just the Unit name and branches for Interface and Implementation sections, but clicking on the + box to the left of any branch will open up its sub-branches or twigs, in more and more detail until individual constants, types and variables are displayed as well as procedure and function declarations. If you change the file displayed in the main Source Editor window, you need to click on the Refresh button of the Code Explorer to display the structure of the new file.
  • Units...: Opens a pop-up dialog window with a list of the unit files in the current project.Clicking with the mouse on a filename selects that file; click on Open to display that file in the Source Editor. Checking the Multi box allows several files to be selected simultaneously, and they will all be opened in the Source Editor (but only one at a time will be displayed). This Menu Option is rather like the Project -> Project Inspector option, but only displays the list of Unit files and allows them to be opened.
  • Forms...: Opens a pop-up dialog window with a list of the Forms in the current project, and allows the selection of one or more of them for display.
  • View Unit Dependencies: Opens a pop-up dialog window that shows, in a tree-like manner, the structure of dependencies of the currently open unit file. Most of the files listed as dependencies will have their own + boxes, which allow the dependencies of the individual files to be explored, often in a highly recursive manner.
  • Toggle form / unit view F12: Toggles whether the Source Editor or the current Form is placed on the top layer of the Desktop, and given focus. If the Source Editor has focus, then you can edit the source code; if the Form is given focus, you can manipulate the components on the desktop and edit the appearance of the Form. The easiest way to toggle the display between Editor and Form is to use the F12 key on the keyboard, but the same effect is achieved by selecting this option on the Main Menu.
  • Messages: A window that displays compiler messages, showing the progress of a successful compilation or listing the errors found.
  • Search Results: A window that displays the results of find in files.
  • Debug windows: Opens a pop-up menu with several options for operating and configuring the Debugger. See below where the debugger is described.

The Project sub-menu

  • New Project: Create a new project. A pop-up dialog window appears offering a choice of types of project to create.
  • New Project from file: A Navigation dialog window appears, alowing selection of a file from which to create a new project.
  • Open Project Open a project which has already been created and saved. A navigation dialog appears with a list of Lazarus Project Information (.lpi) files from which a project may be chosen.
  • Open Recent Project: Displays a pop-up list of recent projects on which you have been working, and allows selection of one of these.
  • Save Project: Similar to File -> Save: all the files of the current project are saved; if they have not previously been saved, there is a prompt for filename(s)- similar to Save Project As...
  • Save Project As...: Prompts for filename to save project. A default filename of Project1.lpi is offered, but you should choose your own filename. Lazarus will not permit you to use the same name for the Project file and the Unit File (see below).
  • Publish Project: Creates a copy of the whole project. If you want to send someone just the sources and compiler settings of your code, this function is your friend. A normal project directory contains a lot of information. Most of it is not needed to be published: the .lpi file contains session information (like caret position and bookmarks of closed units) and the project directory contains a lot of .ppu, .o files and the executable. To create a lpi file with only the base information and only the sources, along with all sub directories use "Publish Project". In the dialog you can setup the exclude and include filter, and with the command after you can compress the output into one archive. See Lazarus IDE Tools
  • Project Inspector: Opens a pop-up dialog with a tree-like display of the files in the current project. Allows you to add, remove or open selected files, or change options of the project.
  • Project Options...: Opens a pop-up dialog window with tabs for setting options for Application (Title, Output Target file name), Forms (allowing you to select among the available forms, make them Auto-create) and Info (specifying whether editor information should be saved for closed files, or only for project files). I'M NOT REALLY VERY SURE WHAT IS THE SIGNIFICANCE OF THIS: HELP!!
  • Compiler options ...: (Recently moved here from the Run Menu). Opens a multi-page tabbed window which allows configuration of the compiler. Tabs include Paths which allows definition of search paths for units, include files, libraries etc as well as allowing choice of widget type for the forms (gtk, gnome, win32); Parsing which allows choice of rules for parsing source programs, Code which allows choice of optimisation for faster or smaller programs, choice of target processor, types of checks, heap size etc; Linking allowing choice of whether or how to use debugging, static or dynamic libraries, and whether to pass options through to the linker; Messages to define what type of messages should be generated during error conditions; Other which allows decision to use default configuration file (fpc.cfg) or some other file; Inherited which shows a tree structure diagram to indicate how options have been inherited from units already incorporated; Compilation which allows definition of commands to be executed before or after the compiler is launched and can allow use of Make files.
  • Add editor file to Project: Add the file currently being edited to the Project
  • Remove from Project: Gives a pop-up menu of files available for removal from project.
  • View Source: No matter which file you are editing, takes you back to the main program file (.dpr)or the main .pas file if there is no .dpr.
  • View ToDo List:Opens a box with a list of ToDo items associated with this project. (I don't think this has been implemented yet, because the controls in the box don't do very much!).

The Run sub-menu

  • Build: Causes Lazarus to build (ie compile) any files in the project that have been changes since the last build.
  • Build all: Builds all files in the project, whether or not there have been any changes.
  • Abort build: Stop the build process once it is running - either you have remembered that you did something silly and want to stop the build, or the system seems to be taking far too long and something is obviously wrong.
  • Run: This is the usual way to launch the compiler and, if compilation is successful, to start execution of the application. What actually happens is that Lazarus saves a copy of your files, then starts the compiler and linker, then begins execution of the final linked binary program.
  • Pause: Suspend execution of the currently running program. This may allow you to inspect any output that has been generated; execution may be resumed by selecting Run again.
  • Step into: Used in conjunction with the debugger, causes execution of the program one step at a time up to a bookmarked point in the source.
  • Step over: Causes stepwise execution up to the statement marked, then skips the marked statement, and continues execution at normal speed. Useful in trying to isolate a statement that introduces a logical error.
  • Run to cursor: Causes execution at normal speed (ie NOT one statement at a time) until the statement is reached where the cursor is located; then stops. Resume execution at normal speed by selecting Run.
  • Stop: Cease execution of the running program. Cannot be resumed by selecting Run; this will start the program again from the beginning (re-compiling if necessary).
  • Run Parameters: Opens a multi-page pop-up window which allows command-line options and parameters to be passed to the program to be executed; allows selection of display to run program (eg a remote X terminal may be used in Linux); some system Environment variables may be overridden.
One very important use of this sub-menu is to activate a terminal window in which conventional Pascal console input/output is displayed. If you are developing a console-mode Pascal program (ie one that doesn't use the Graphical User Interface with its forms, buttons and boxes) then you should check the box for "Use launching application". The first time you do this and try the Compile/Run sequence, you will probably get a rude message to say
"xterm: Can't execvp /usr/share/lazarus//tools/runwait.sh: Permission denied".  
If this happens, you need to change the permissions on the appropriate file (for example using chmod +x filename, or using the Windows utility for changing permissions); you might have to do this as root. After this, each time you launch you program, a console box will appear and all your text i/o (readln, writeln etc) will appear in it.
After your program has finished execution, a message "Press enter" appears on the screen. Thus any output your program generated will remain on the screen until you have had a chance to read it; after you press 'enter' the console window closes.
See the separate tutorial on Console Mode Pascal programming.
  • Reset debugger: Restores the debugger to its original state, so that breakpoints and values of variables etc are forgotten.
  • Build file: Compile (build) just the file that is currently open in the Editor.
  • Run file: Compile, link and execute just the currently open file.
  • Configure Build + Run File: Opens a multi-page tabbed window with options to allow for build of just this file when Build Project is selected, allows selection of the working directory, the use of various Macros, etc. Then Builds and Runs the file.

NOTE: I AM NOT REALLY CLEAR IN WHAT CIRCUMSTANCES YOU WOULD USE THESE LAST THREE SELECTIONS; IN PARTICULAR, WHAT HAPPENS TO OTHER FILES THAT ARE USED BY THE PROGRAM? User:Kirkpatc

The Components sub-menu

  • Open Package: Displays a [http:../../kbdata/OpenPackageSnapshot.png list of installed packages], with an invitation to [http:../kbdata/PackageContentsSnapshot.png open one or more of them], or to select various general or compiler options.
  • Open Package File: Open one of the files in the selected package.
  • Open Recent Package: Open a package that was opened recently.
  • Add Active Unit to Package: Place the unit file (currently in the editor) into a package.
  • Package Graph: Displays a [http:../../kbdata/PackageGraphSnapshot.png graph] showing the relationships of the packages currently being used (if you aren't using any other packages, the Lazarus package and the FCL and LCL will be displayed).
  • Configure custom components: If you have created some components, allows you to configure them.

The Tools sub-menu

  • Configure custom tools: Allows the user to add various external tools (usually macros) to the toolkit

  • Quick syntax check: Perform a quick check of the syntax in your source file without actually compiling anything. Essential step in developing long or complicated programs, where you don't want to waste time compiling if the code is wrong.
  • Guess unclosed block: useful utility if you have a complex nested block structure and you have left out an 'end' somewhere
  • guess misplaced IFDEF/ENDIF: useful if there is a complex or nested macro structure and you think you have left out an ENDIF directive
  • Make resource string: I NEED SOME HELP IN DESCRIBING THE FUNCTION OF THIS SELECTION: I HAVE NEVER USED IT MYSELF AND DON'T REALLY KNOW WHAT IT DOES. User:Kirkpatc
  • Diff: Allows comparison between two files (or, usually, two versions of the same file) to find differences. Options to ignore white space at beginning or end of lines or differences in line termination: CR+LF versus LF). Useful for checking if there have been changes since last CVS update etc.

  • Check LFM file in editor: Allows inspection of the LFM file which contains the settings that describe the current form
  • Convert Delphi unit to Lazarus unit: Helps in porting Delphi applications to Lazarus; makes the necessary changes to the source file. See Lazarus For Delphi Users and Code Conversion Guide.
  • Convert DFM file to LFM: For porting from Delphi to Lazarus: converts the Form Description files from Delphi to Lazarus. See Lazarus For Delphi Users and Code Conversion Guide.

  • Build Lazarus: Launches a re-build of Lazarus from the most recently downloaded or updated CVS files. Hit the button and sit back to watch it happen! (track the process on your Messages window).
  • Configure "Build Lazarus": Allows the user to determine which parts of Lazarus should be re-built, and how. For example, you could select to have just the LCL re-built, or to have everything except the examples built; you can select which LCL interface to use (ie which set of widgets), and you can select the target operating system and specify a different target directory.

The Environment sub-menu

http://lazarus-ccr.sourceforge.net/kbdata/EnvironmentMenuSnapshot.png

{
  • **Environment options** @@@Displays a multi-page window with tabs for **Files** - allowing the user to specify path to default directory, compiler, source directory and temporary directory for compilation; **Desktop** - options for Language, Auto save behaviour, saving desktop properties, hints for component palette and speed buttons; **Windows**, to allow specification of size and behaviour of the various windows; **Form Editor** - choose colours for editing forms; **Object Inspector** - choose colour and height of items; **Backup** - specify how to backup files when editing; **Naming** - specify what extension to use in naming pascal files ('.pp' or '.pas'), whether to save files with names in lowercase, whether to perform auto-delete or auto-rename.
}
{
  • **Editor options** @@@Multi-page window, with tabs for **General** - determines behaviour like auto-indent, bracket highlighting, drag-drop editing, scrolling, syntax highlighting, showing hints, size of block indent and tabs, limit of Undo; **Display** - options for showing line numbers, presence of gutters, size and type of font for editor, and contains a preview panel showing the colours of the various syntax features such as comments, directives, punctuation, errors and breakpoints; **Key Mappings** - options to select Lazarus or Turbo Pascal scheme; **Color** - allows choice of colour scheme for text features, for a number of language types such as Object Pascal, C++, Perl, HTML, XML and shell scripts. It shows preview panel again (for whichever language is selected); **Code Tools** - allows selection of features like Identifier Completion, tooltips, specification of template file names, specific templates for code completion.
}
{
  • **Debugger Options** @@@Multi-page window with tabs for **General** - choose debugger: none, GNU debugger (gdb) or gdb through SSH, specify search paths for debuggers,and specific options for chosen debugger; **Event log** - specify whether to clear log on run, and which messages to display; **Language Exceptions** - select which exceptions can be ignored; **OS Exceptions** - allows user to add certain signals which apply to current operating system.
}
{
  • **Code Tool Options** @@@Multi-page window, tabs for **General** - Allows entry of additional source search paths, specify Jumping Method; **Code Creation** - determines whether created code is added before or after certain features; **Words** - determines whether Pascal keywords are to be entered in upper or lower case, or as Capitalised Words; **Line Splitting** - establish rules about where lines are allowed to be split (before or after punctuation, after keywords etc); **Space** - decide whether a space is to be added automatically before or after certain syntactic features such as keywords or punctuation marks.
}
{
  • **Code Tools Defines Editor** @@@I NEED SOME HELP IN DESCRIBING THIS, AS I HAVEN'T A CLUE WHAT THIS ITEM IS FOR! [ChrisKirk|]
}

---

{
  • **Re-scan FPC Source directory** Looks through the directory again. Lazarus uses the fpc sources to generate correct event handlers and while looking for declarations. If somebody changes the directory in the environment options, then this directory is rescanned, to make sure lazarus uses the version stored in that location. But if this directory has changed without lazarus noticing, then you may get some errors when designing forms or doing "Find declaration". If you get such an error, you can do two things:
  1. @@@ @@@Check the fpc source directory setting in the environment option.
  2. @@@ @@@Re-scan FPC source directory.
}

The Windows sub-menu

Contains a list of the currently opened files and the available windows such as Source Editor, Object Inspector and Project Inspector. Clicking on the name of one of the windows brings it to the foreground and gives it focus.

The Help sub-menu

At present this has only one selection:

  • About Lazarus Displays a pop-up box with some information about Lazarus.

Eventually there will be a full on-line Help service, with information about Pascal syntax, the use of the IDE, how to use, modify or create Components, and hints on how to perform certain tasks. This part of the Documentation section (the thing you are currently reading) represents the beginning of the process. We need contributions from anyone who feels able to provide them: the WiKi is very easy to edit.

The Button bar

A small toolbar area on the left of the main editor window, just below the Main Menu and to the left of the Component Palette, contains a set of buttons which replicate frequently-used Main Menu selections:

New unit, Open (with a down-arrow to display a drop-down list of recently used files), Save, Save all, New Form, Toggle Form/Unit (ie show either form or source code of Unit), View Units, View Forms, Run (ie compile and Run), Pause, Step Into, Step over (the last two are Debugger functions).

The Component Palette

A Tabbed toolbar which displays a large number of icons representing commonly used components for building Forms.

{

Each tab causes the display of a different set of icons, representing a functional group of components. The left-most icon in each tabbed group is an obliquely leftward-facing arrow, called the Selection Tool.

If you allow the mouse cursor to hover over any of the icons on the Component Palette, without clicking on the icon, the title of that component will pop-up. Note that each title begins with a 'T' - this signifies 'Type' or more accurately 'Class' of the component. When you select a component for inclusion in a form, the Class is added to the **type** section of the **interface** part of the Unit (usually as part of the overall TForm1), and an **instance** of that class is added to the **var** section (usually as the variable Form1). Any **Methods** that you design to be used by the Form or its Components (ie Procedures or Functions) will be placed in the **implementation** part of the Unit

}%%%

%%% In the following list of the Components, you will find links to files that contain descriptions of the Units in which they are found. If you want to find out about the properties of a particular component, it is often worth looking at the Inheritance of that component and then inspecting the properties of the base type from which it is derived. For example, to understand TMaskEdit it is also useful to examine TCustomMaskEdit.%%%

    • TABS** (the names are largely self-explanatory):
{
  • **[StdCtrls|Standard]** @@@Frequently used components: [MenuUnit|TMainMenu], [MenuUnit|TPopupMenu], [ButtonsTxt|TButton], TLabel, TEdit, TMemo, TToggleBox, TCheckBox, TRadioButton, TListBox, TComboBox, TScrollBar, TGroupBox, TStaticText, [ExtCtrls|TRadioGroup], TCheckGroup, [ExtCtrls|TPanel], TActionList
  • **[ExtCtrls|Additional]** @@@More, often-used components: [ButtonsTxt|TBitBtn], [ButtonsTxt|TSpeedButton], [ExtCtrls|TImage], TShape, TBevel, TPaintBox, TNotebook, TLabeledEdit, TSplitter, [MaskEdit|TMaskEdit], TCheckListBox, [FormsTxt|TScrollBox], [FormsTxt|TApplicationProperties], TStringGrid, TDrawGrid, TPairSplitter
  • **[ComCtrls|Common] Controls** @@@TTrackBar, TProgressBar, TTreeView, TListView, TStatusBar, TToolBar, TUpDown, TPageControl, TImageList
  • **[DialogsTxt|Dialogs]** @@@TOpenDialog, TSaveDialog, TSelectDirectoryDialog, TColorDialog, TFontDialog, TOpenPictureDialog, TSavePictureDialog, TCalendarDialog, TCalculatorDialog %%%

Several useful **[DialogExamples|Dialog]** procedures or functions don't appear on the Palette, but are easily used as direct calls from your source program. %%%For several good examples of the use of Components see the $LazarusPath/lazarus/examples subdirectory of your source installation. Many of the programs show how to use dialogs and other components directly without using the IDE and component palette or having a separate form definition file: all the components are fully and explicitly defined in the main Pascal program. Other example programs make full use of the IDE.  %%%Some examples don't work straight away: you may need to play about with paths and permissions of files or directories. If you want to compile any of the examples, make sure that you have read/write/execute permissions for the files and directories, or copy the files to a directory where you do have the appropriate permissions.%%%Try running the 'testall' program to see a menu of the available components together with small example test forms for most of them; then inspect the code to find out how they work!

  • **Misc** @@@[DialogsTxt|TColorButton], TSpinEdit, TArrow, TCalendar, TEditButton, TFileNameEdit, TDirectoryEdit, TDateEdit, TCalcEdit, TFileListBox
  • **Data Controls** @@@Data-aware components, which largely replicate the Standard and Additional groups but are applicable to Databases: TDBNavigation, TDBText, TDBEdit, TDBMemo, TDBImage, TDBListBox,TDBComboBox, TDBCheckBox, TDBRadioGroup, TDBCalendar, TDBGroupBox, TdbGrid
  • **Data Access** @@@TDatasource
  • **System** @@@[ExtCtrls|TTimer], TIdleTimer, TProcess
  • **SynEdit** @@@A group of components to help interfacing with other languages and software tools. SynEdit is an advanced multi-line edit control, for Borland Delphi, Kylix and C++Builder. It supports Syntax Highlighting and code completion, and includes exporters for html, tex and rtf. It is a full-VCL/CLX control, meaning it is not a wrapper for Microsoft Windows controls, and no run-time library is required; this make SynEdit a crossplatform component. Compatibility with FreePascal is also planned, and SynEdit is the edit component in Lazarus IDE. see http://synedit.sourceforge.net. TSynEdit, TSynAutoComplete, TSynExporterHTML, TSynMacroRecorder, TSynMemo, TSynPasSyn, TSynCppSyn, TSynJavaSyn, TSynPerlSyn, TSynHTMLSyn, TSynXMLSyn, TSynLFMSyn, TSynUNIXShellScriptSyn, TSynCssSyn, TSynPHPSyn, TSynTeXSyn, TSynSQLSyn, TSynMultiSyn

To use the Palette, there must be an open form on view in the editor (if there isn't one, select File -> New Form). Click on the icon in the appropriate tab of the Palette for the component you want to use, then click on the Form, near where you want the component to appear. When the desired component appears, you can select it by clicking with the mouse, then move it to the exact place on the Form where you want it and adjust its size. Adjustments can be made to the appearance either by altering the picture itself on the Form using the mouse, or by changing the relevant Property in the Object Editor for that component.

If you install additional components, either those you have written yourself, or some coming as a package from some other source, then extra tabs with the relevant icons will appear in your Component Palette. These new components can be selected and used on your forms in the same way as those supplied by default.

}

The Debugger

Still to be written.

The Lazarus files

   (Thanks to Kevin Whitefoot.)
   (Additions by Giuseppe Ridinò, User:Kirkpatc and Tom Lisjac)

When you save you will actually be saving two files:

  xxx.pas and yyy.lpr 

(You save more than that but those are the ones you get to name). The project file (lpr) and the unit file (pas) must not have the same name because Lazarus will helpfully rename the unit (inside the source code) to the same as the unit file name and the program to the name of the project file (it needs to do this or the compiler will probably not be able to find the unit later when referred to in the project file). Of course to be consistent it changes all the occurrences of unit1 to xxx.

So if you are saving a project called again, trying to save again.pas and again.lpr fails because unit names and program names are in the same name space resulting in a duplicate name error.

So here is what I ended up with:

e:/lazarus/kj/lazhello:

total 4740  free 76500
-rwxrwxrwx   1 kjwh     root  4618697 Mar 24 11:19 again.exe
-rw-rw-rw-   1 kjwh     root     3002 Mar 24 11:21 again.lpi
-rw-rw-rw-   1 kjwh     root      190 Mar 24 11:18 again.lpr
-rw-rw-rw-   1 kjwh     root      506 Mar 24 11:08 againu.lfm
-rw-rw-rw-   1 kjwh     root      679 Mar 24 11:08 againu.lrs
-rw-rw-rw-   1 kjwh     root      677 Mar 24 11:08 againu.pas
-rw-rw-rw-   1 kjwh     root     2124 Mar 24 11:08 againu.ppu
-rwxrwxrwx   1 kjwh     root      335 Mar 24 11:07 ppas.bat

Note that there are many more files than the two that I thought I was saving.

Here is a brief note about each file:

again.exe: The main program binary executable. Win32 adds an "exe" extension. Linux has none. This file will be huge on Linux due to the inclusion of debugging symbols. Run the "strip" utility to remove them and substantially shrink the executable size.

again.lpi: This is the main file of a Lazarus project (Lazarus Project Information); the equivalent Delphi main file of an application will be the .dpr file. It is stored in an XML format.

again.lpr: The main program source file. Despite its lazarus specific extension it is in fact a perfectly normal Pascal source file. It has a uses clause that lets the compiler find all the units it needs. Note that the program statement does not have to name the program the same as the file name.

againu.lfm: This is where Lazarus stores the layout of the form unit. Lazarus uses this to generate a resource file that is included in the initialisation section of the againu.pas unit. Delphi dfm files can be converted to lfm format in the Lazarus IDE using the Tools->Convert DFM file to LFM utility.

again.lrs: This is the generated resource file. Note that it is not a Windows resource file.

againu.pas: The unit that contains the code for the form.

again.ppu: This is the compiled unit.

ppas.bat: This is a simple script that links the program to produce the executable. If compilation is successfull, it is deleted by the compiler.